Bug 18569 - Getting error while building F# application with xbuild tool
Summary: Getting error while building F# application with xbuild tool
Alias: None
Product: Runtime
Classification: Mono
Component: packaging ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Duncan Mak
Depends on:
Reported: 2014-03-25 08:52 UTC by Ram Chandra
Modified: 2017-05-16 22:38 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ram Chandra 2014-03-25 08:52:32 UTC
I am trying to build an F# project targeting "Profile47" and I am getting an error. I have downloaded the F# project from here: "https://github.com/fsharp/fsharp/tree/master/tests/projects/Sample_VS2012_FSharp_Portable_Library". I have got this link from "bug 18396".

Steps to reproduce :

1. Open the "Sample_VS2012_FSharp_Portable_Library" F# project.
2. open terminal and run the following command :

      "xbuild /Users/jatin66/Desktop/latest/fsharp-  master/tests/projects/Sample_VS2012_FSharp_Portable_Library/Sample_VS2012_FSharp_Portable_Library.fsproj"

3. The Build will be failed and error will occurred.

Excepted Result: Application will build without any error.

Actual Result: Build error when building application with xbuild tool.

Note: I also tried to build the application with xamarin studio but getting the same error. 

Regression Status: I observed that this issue is also coming with stable builds (4.2.3 (build 60)).

Error in terminal: https://gist.github.com/Sadik1/afd410a1e7de53951264


=== Xamarin Studio ===

Version 4.2.4 (build 32)
Installation UUID: 6ea47b0d-1852-4aaf-808d-373ff0a5002b
	Mono 3.2.7 ((no/40f92d5)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 302070000

=== Xamarin.Android ===

Version: 4.12.1 (Trial Edition)
Android SDK: /Users/jatin66/Desktop/Backup/android-sdk-macosx
	Supported Android versions:
		1.6   (API level 4)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Apple Developer Tools ===

Xcode 4.6.3 (2068)
Build 4H1503

=== Xamarin.Mac ===

Xamarin.Mac: 1.6.27

=== Xamarin.iOS ===

Version: (Trial Edition)
Hash: 58c3efa
Build date: 2014-10-03 18:02:26-0400

=== Build Information ===

Release ID: 402040032
Git revision: a160c35dac9ab9fd32eeadaa171216316d5a5133
Build date: 2014-03-12 13:55:08-04
Xamarin addins: a779416ceabd54981ce812771a4061c942e8b872

=== Operating System ===

Mac OS X 10.7.5
Darwin Jatin66s-iMac.local 11.4.2 Darwin Kernel Version 11.4.2
    Thu Aug 23 16:25:48 PDT 2012
    root:xnu-1699.32.7~1/RELEASE_X86_64 x86_64
Comment 1 Mikayla Hutchinson [MSFT] 2014-03-26 14:28:43 UTC
Missing targets file.
Comment 2 Alexander Köplinger [MSFT] 2017-05-16 22:38:56 UTC
We're packaging that file now, closing.