Bug 1853 - Constant re-uploads in build/run cycle
Summary: Constant re-uploads in build/run cycle
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 2.8.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Alan McGovern
Depends on:
Reported: 2011-11-03 08:50 UTC by kenny goers
Modified: 2011-11-25 06:25 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description kenny goers 2011-11-03 08:50:50 UTC
Everytime I run the same code for debug the .APP file gets re-uploaded EVERYTIME.  Should only be done once if no changes are made.  This was supposedly fixed in MonoDevelop 2.8.2?  Also running MonoTouch 5.0.0
Comment 1 Sebastien Pouliot 2011-11-03 09:24:04 UTC
-> monodevelop
Comment 2 Mikayla Hutchinson [MSFT] 2011-11-03 09:27:56 UTC
It was, but 2.8.2 hasn't been released yet.

*** This bug has been marked as a duplicate of bug 1569 ***
Comment 3 Sebastien Pouliot 2011-11-03 09:56:18 UTC
hmmm... Lluis said it was released on [Mono-list] and I have already updated to 2.8.2 before your previous comment. It could be a dupe... but it could be the real thing too!
Comment 4 Alan McGovern 2011-11-03 09:58:50 UTC
Ah, it has been released. Let me get my testing boots on and see what's going wrong.
Comment 5 Alan McGovern 2011-11-03 10:20:07 UTC
I have a simple project here which does not experience this issue. Would you be willing to give us access to your solution, or a simpler solution which demonstrates the same issue, so we can diagnose and fix this? Can you also verify that you are running MonoDevelop 2.8.2 by clicking on MonoDevelop -> About MonoDevelop. If you followed the automatic update process then everything should be fine, but it would help to verify that.
Comment 6 Alan McGovern 2011-11-11 06:34:30 UTC
Is this issue still affecting you? If so, would you be able to provide us with access to your solution (or any other solution with the same issue) so we can diagnose the issue?
Comment 7 kenny goers 2011-11-11 08:12:55 UTC
This isn't as big a problem for us, what seems to be happening is that the dev environment forgets it's already deployed changes, doing combinations in the env such as Upload to Device followed by Run Item tend to cause the upload to happen multiple times.  It doesn't happen every time and seems to be more related to mixing the commands.
Comment 8 Alan McGovern 2011-11-25 06:25:49 UTC
I can't reproduce this problem with the code we have in git master and I've tried a fair few variations. There have been a number of changes relating to this code so the odds are pretty high it's been fixed.

If this is still a problem when we release the next version of MonoDevelop, please reopen this. Also, if you can come up with a set of steps which triggers the issue in MonoDevelop 2.8.2 I could also try them with the latest code and ensure that the bug is actually gone.

Thanks for reporting this!