Bug 18514 - Could not open port for debugger. Another process may be using the port
Summary: Could not open port for debugger. Another process may be using the port
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-03-21 11:55 UTC by zeedorq
Modified: 2015-03-06 15:10 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
A screenshot of the error message. (101.72 KB, image/png)
2014-03-21 11:55 UTC, zeedorq
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description zeedorq 2014-03-21 11:55:12 UTC
Created attachment 6378 [details]
A screenshot of the error message.

I've installed Monodevelop on two Fedora 20 x86_64, on both these computers the debugger doesn't work, and I'm unable to run/debug projects. The error is "Could not open port for debugger. Another process may be using the port", I've checked my ports and no process is using this port (10000).
Comment 2 zeedorq 2014-03-21 20:14:46 UTC
Steps to reproduce:
* Start MonoDevelop
* Open/create any C# application
* Start debugging
Comment 3 zeedorq 2014-03-22 09:13:59 UTC
It seems that this bug is due to some variable not being present in Gnome any more, I tried Monodevelop on Fedora 20 x86_64 lxce and Gnome and neither debugger worked. It got it working on KDE.
Comment 4 zeedorq 2014-03-22 09:16:33 UTC
I mean Fedora Xfce
Comment 5 Mikayla Hutchinson [MSFT] 2014-03-22 17:44:36 UTC
2.8 is a very old version, in more recent versions we use randomly assigned ports so this cannot happen.

What error are you getting with 4.x?
Comment 6 zeedorq 2014-06-04 14:27:15 UTC
I don't know the error in 4.x because I soon switched to KDE for being able to develop in C# on my Linux. I tried three different versions I think, but all had the same problem. So I switched to KDE and currently I'm using version 5.x. Sorry about the delay on the response.
Comment 7 Jeffrey Stedfast 2015-03-06 15:10:29 UTC
I guess this means it's fixed?