Bug 1847 - Provisioning profile / entitlements might be incorrect for adhoc builds
Summary: Provisioning profile / entitlements might be incorrect for adhoc builds
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 4.x
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2011-11-03 05:59 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2012-05-18 19:35 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Rolf Bjarne Kvinge [MSFT] 2011-11-03 05:59:40 UTC
See this thread:

In particular TestFlight installs fails due to incorrect entitlements for adhoc profiles.

According to TestFlight support:

This appears to be an issue with how Apple creates provisioning profiles
 enabled with iCloud. Recently Apple enabled iCloud on all App IDs in the
 portal. When you create a development profile the iCloud entitlements are
 properly included. However, any distribution profile (eg. Ad Hoc) does not
 include these entitlements for some reason.

 When you specify Entitlements in the Summary tab in Xcode, these
 entitlements are compiled into the binary. When you archive your application
 using an Ad Hoc Distribution profile, the entitlements are not included in
 the embedded.mobileprovision file. When iOS tries to install the app it
 compares the entitlements in the binary with the ones in the
 embedded.mobileprovision. Because the iCloud entitlements exist in the
 binary but not in the .mobileprovision the app fails to install.

 If you archive and share the application using the development profile that
 correctly includes the iCloud entitlements the app can be installed as the
 entitlements exist in both the binary and the embedded.mobileprovision file.

 This appears to be a bug on Apples end. The current workaround, as far as we
 have worked out, is to:

 1) If you do not require iCloud or keychain entitlements, do not enable
 entitlements on the Summary tab in Xcode and code sign your ad hoc with the
 Distribution profile 

 2) If you do require iCloud or keychain entitlements, make sure you have
 setup your entitlements on the Summary tab in Xcode and code sign your ad
 hoc with the Development profile

 There are a couple threads on the dev forums discussing this issue:


 Please let us know if you have any further issues. We will continue to
 monitor this and hope that Apple fixes this shortly.
Comment 1 Nic Wise 2011-11-03 06:07:02 UTC
Turning off iCloud in the provisioning area in iOS provisioning, fixes it.

iOS provisioning -> App Id's -> your app id -> untick icloud and then get your cert down again
Comment 3 Rolf Bjarne Kvinge [MSFT] 2012-05-18 19:35:13 UTC
I haven't seen this issue again, I presume Apple fixed it.