Bug 18293 - Getting build error "Error parsing XML: no element found"
Summary: Getting build error "Error parsing XML: no element found"
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 1.12.x
Hardware: PC Windows
: High normal
Target Milestone: 1.12 (Merge)
Assignee: dean.ellis
Depends on:
Reported: 2014-03-11 02:10 UTC by narayanp
Modified: 2014-03-24 07:56 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Sample (23.54 KB, application/zip)
2014-03-11 02:10 UTC, narayanp

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description narayanp 2014-03-11 02:10:22 UTC
Created attachment 6279 [details]

Steps to reproduce:
1. Open attached sample.
2. Build the sample.

Actual Result: It is giving build error when using Xamarin for VS 1.12.235 which is having Xamarin.Android

Expected Result: Application should build successfully.

Supplement info:
Build Output: https://gist.github.com/saurabh360/9d3e5f45982d7fa3bd2c

Environment details:
All Windows
X.S 4.2.3(build 60)
Xamarin for VS 1.12.235
VS 2013/2012/2010

Regression Status: 
REGRESSION: It is working fine with stable Xamarin.Android 4.12.1
Comment 1 dean.ellis 2014-03-11 10:54:32 UTC
I can't replicate this issue with the 1.12.237 version of Xamarin for VS. The sample project builds fine on my machine. I have confirmed it is using the 19.0.1 version of the android sdk tools
Comment 2 Mohit Kheterpal 2014-03-11 13:09:11 UTC
I have tried to Reproduce this issue, but unable to reproduce it. I have tried to reproduce it on three machine including narayanp machine but unable to reproduce it.

I have also checked this issue with SDK tools 22.3 and 22.6. But it builds successfully.

As of now I am closing this issue. 

@narayanp : Please reopen it if you are getting this issue again.
Comment 3 narayanp 2014-03-24 07:56:33 UTC
I am also unable to reproduce this issue. 

VS 2013/2012/2010
Xamarin for VS 1.12.247

Hence, closing this issue. I'll reopen the same if get the same issue in future for the attached sample.