Bug 18264 - Problem with parameters in a function
Summary: Problem with parameters in a function
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 7.0.6.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2014-03-08 13:18 UTC by Alain
Modified: 2016-05-24 21:20 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alain 2014-03-08 13:18:18 UTC
We have a weird problem. We pass data parameters of a function. 

On the IOS simulator, no problem. IPad, one of the parameters to NULL then it is well filled out. 

We tried to change the order of parameters and it solves the problem in DEBUG mode.

In RELEASE mode, again the problem. 

Anyway, it is not very normal like situation. Do you know this problem? 

Comment 1 Sebastien Pouliot 2014-03-09 00:15:34 UTC
There was a  known issue in 7.0.6 wrt ARM register allocation (only on device). This was fixed in 7.0.7 - can you try this version to see if this solve the issue ?

Otherwise we'll need a test case to investigate what is going wrong.
Comment 2 Alain 2014-03-10 06:06:46 UTC

we have this and we have this problem in RELEASE MODE. In ebug mode, that's running :


=== Xamarin Studio ===

Version 4.2.3 (build 59)
Installation UUID: 3363639e-cfcb-437b-ade7-72fcbb862f16
	Mono 3.2.7 ((no/40f92d5)
	GTK+ 2.24.23 theme: Raleigh
	GTK# (
	Package version: 302070000

=== Apple Developer Tools ===

Xcode 5.0.2 (3335.32)
Build 5A3005

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: fb4bc7b
Build date: 2014-17-02 17:43:23-0500

=== Xamarin.Android ===

Not Installed

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 402030059
Git revision: 828c2a91b515daaac7e57bc69fcfda6178d4ec01
Build date: 2014-02-18 18:05:23+0000
Xamarin addins: 3bdcc713bdc4b0c04973f3a31b6d47ad3e205962

=== Operating System ===

Mac OS X 10.9.2
Darwin rogistermac.appl-lan.be 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 3 Sebastien Pouliot 2014-03-10 08:54:33 UTC
Since this happens on 7.0.7 it must be something else.

We'll need a test case to investigate what is going wrong.
Comment 4 Alain 2014-03-10 14:03:10 UTC
how can you help to see what the problem is. 

We note that we have this problem with the function that we have to reduce no longer have the problem of AOT compilation. 

This morning, we tried to see what was happening but it is incomprehensible to us. It works perfectly well with the simulator in debug mode on the iPad. But in release mode, it does not work. The try catch function always returns us "Object Reference" ... file unknow. 

it isn't a problem setting as we thought at first, because they are now properly filled at the beginning of the function, but it is within the try catch directly to the first line of the function to a variable.

Comment 5 Sebastien Pouliot 2014-03-14 09:07:09 UTC
> how can you help to see what the problem is. 

As stated in comment #1 and #3:

>> We'll need a test case to investigate what is going wrong.
Comment 6 Alain 2014-03-14 10:16:12 UTC
it is impossible for us to provide a test for this. 

what we see with our application and we do not know why. 

In debug mode on the iPad, no problem. 

In RELEASE mode, there are problems quite bizarre and we do not know why. 

For error, we bypassed the problem by doing it otherwise but it is not normal.
Comment 7 Sebastien Pouliot 2016-05-24 21:20:50 UTC
We never had a way to reproduce this.

If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!