Bug 18263 - Creating a new Universal Empty iOS project crashes on launch
Summary: Creating a new Universal Empty iOS project crashes on launch
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: PC Mac OS
: --- critical
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-03-08 01:28 UTC by James Clancey
Modified: 2014-03-27 10:30 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description James Clancey 2014-03-08 01:28:17 UTC
When you create a new universal empty project it crashes because the info.plist has MainStoryboard_iPhone set for the storyboard. But since it's an empty project it doesn't have a storyboard.


=== Xamarin Studio ===

Version 4.3.3 (build 2)
Installation UUID: 52089b5f-87fd-4a01-8acf-c63eac855683
Runtime:
	Mono 3.2.7 ((no/40f92d5)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 302070000

=== Apple Developer Tools ===

Xcode 5.0.2 (3335.32)
Build 5A3005

=== Xamarin.iOS ===

Version: 7.1.5.1 (Business Edition)
Hash: ccb147d
Branch: 
Build date: 2014-05-02 09:45:53-0500

=== Xamarin.Android ===

Version: 4.12.1 (Business Edition)
Android SDK: /Users/Clancey/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 403030002
Git revision: 89301538d2f1e41888247489294fdb08a6888119
Build date: 2014-02-23 23:26:23-05
Xamarin addins: 21512f84ba13e6f7264bb24d505927e2b302c81c

=== Operating System ===

Mac OS X 10.9.2
Darwin Jamess-MacBook-Pro-3.local 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 1 Jeffrey Stedfast 2014-03-08 10:33:59 UTC
this should be fixed in the next release
Comment 2 Akhilesh kumar 2014-03-27 10:30:27 UTC
I have checked this issue with latest master builds:

=== Xamarin Studio ===

Version 4.2.4 (build 266)
Installation UUID: b1fc3b76-cf00-405e-a0a1-3839ac11fe6d
Runtime:
	Mono 3.2.6 ((no/9b58377)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 302060000

=== Apple Developer Tools ===

Xcode 5.0 (3332.22)
Build 5A1412

=== Xamarin.iOS ===

Version: 7.2.2.14 (Enterprise Edition)
Hash: 16bef0b
Branch: 
Build date: 2014-03-20 12:01:19-0400

=== Build Information ===

Release ID: 402040266
Git revision: 57fa6b7639703775ae1d5c46536e42ab424cb177
Build date: 2014-03-20 12:34:27-04
Xamarin addins: eee141c29724a19529e77b8e743086d95b29f5ba

=== Operating System ===

Mac OS X 10.9.3
Darwin Apples-iMac.local 13.2.0 Darwin Kernel Version 13.2.0
    Tue Mar 11 22:16:58 PDT 2014
    root:xnu-2422.100.4~2/RELEASE_X86_64 x86_64


Now, newly created Universal Empty iOS project does not crash on launch.

Screencast: http://screencast.com/t/8FA0zQeOEp

Hence, closing this issue.

Please, let me know if I have to check any thing else to verify this issue.