Bug 18201 - Deployment hangs with 'Waiting for device...'
Summary: Deployment hangs with 'Waiting for device...'
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 1.12.x
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: dean.ellis
Depends on:
Reported: 2014-03-05 17:39 UTC by Allie Miller
Modified: 2016-05-10 16:58 UTC (History)
19 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Allie Miller 2014-03-05 17:39:05 UTC
When attempting to deploy to a Android 4.4 device/emulator, the deployment hangs with "Waiting for device..."
However, this same deployment from XS completes successfully.

Android Debug Log from "waiting for device" deployment attached.

Versioning Information
Microsoft Visual Studio Ultimate 2013
Version 12.0.30110.00 Update 1
Microsoft .NET Framework
Version 4.5.51641
Installed Version: Ultimate
Xamarin.Android 4.12.01000 (0deb0164)
Visual Studio plugin to enable development for Xamarin.Android.
Comment 2 Sadik Ali 2014-03-06 04:45:17 UTC
We are not sure, what is meant by Case #...... mentioned in Comment#1.

However, on the basis of description in the bug, I have checked this issue on below environments:

Window 7
Microsoft Visual Studio Professional 2013
Version 12.0.21005.1 REL
Microsoft .NET Framework
Version 4.5.50938
Xamarin.Android   4.12.00028

I have deployed android sample application successfully on to a Android 4.4.2 API 19 emulator. Refer screen cast: http://screencast.com/t/gaRAP8Ive

Also I check on VS 2012
Comment 3 Ben 2014-03-28 13:52:36 UTC
While typing here to confirm I have the same problem, the emulator comes alive after ca 12 minutes of 'waiting for device'. So while I thought there was indeed a bug, the app starts showing after ca 10 to 15 minutes. So to the normal user it may appear that there is indeed a bug.

So my suggestion, start again and wait.....
Comment 4 James 2014-04-01 23:15:26 UTC
I can confirm this bug on version 4.12.03003 when trying to debug on a android 4.3 device with VS 2013. Anything you need to fix this bug I'd like to provide
Comment 5 PJ 2014-04-01 23:32:30 UTC
Looks like we have some additional information, moving back to NEW.
Comment 7 Andrew 2014-04-15 07:07:12 UTC
I have the same issue, forever "waiting for device".
It deploys with no problem to 4.1.1.

I tried with Android SDK Emulator and Genymotion.

Windows 8.1
Xamarin.Android   4.12.02001 (a1e3982a)
Comment 9 dean.ellis 2014-04-15 10:50:51 UTC
I have managed to replicate this issue using a genymotion API 19 emulator image connected via dab over wifi. This works previously with a API 16 image.

Investigating now
Comment 10 dean.ellis 2014-04-15 10:57:06 UTC
The issue is the command we use to check if the device is ready is returning additional information

WARNING: linker: libart.so has text relocations. This is wasting memory and is a security risk. Please fix.

The warning lines need to be stripped out (or the code modified to handle additional information)
Comment 11 dean.ellis 2014-04-15 11:06:41 UTC
This seems to be a side effect of the ART runtime.
Comment 12 Dimitar Dobrev 2014-04-28 05:17:58 UTC
Hello, I hit the same issue with an Intel Nexus 5 emulator, Android 4.4.2 (Windows 7 64-bit, Visual Studio 2013). I hope it can be fixed soon.
Comment 14 James 2014-05-08 21:46:27 UTC
problem resolved! In which version we can get this fix?
Comment 15 André Santos 2014-05-09 05:34:06 UTC
How is it solved?

I'm here with my Nexus 5, Android version 4.4.2 with Dalvik Runtime and it stays indefinitely waiting for device...
Comment 16 James 2014-06-10 23:03:35 UTC
Is this fix included in the Xamarin 3.0?
Comment 17 Tomasz Cielecki 2014-07-03 05:32:42 UTC
I can confirm it is also a problem in Android 4.4.4 (Paranoid Android 4.41), running Dalvik VM.
Comment 18 999komi 2014-07-22 14:32:25 UTC
I am having this problem trying to deploy to a Huawei868C.
6>Packaging application..
6>Build started.
6>Build succeeded.
6>Waiting for device..
and then nothing happens.
Comment 19 emorgan 2014-08-06 09:57:37 UTC
If you're using the Xposed Framework on your device, try uninstalling it through the app (the framework, not the app itself). I had this problem on my Nexus 7 until I uninstalled the framework.
Comment 20 Jeremy Thompson 2015-06-29 02:07:55 UTC
.Net 4.5
Xamarin 4.4.2
Nexus5 emulator

I got the same problem 'Waiting for device'. I managed to get past it by setting the Emulators SD Card size to a minimum of 512mb (as the whole of the Mono framework is preloaded on the device - http://docs.xamarin.com/guides/android/advanced_topics/application_package_sizes).

As per the advice here: http://forums.xamarin.com/discussion/comment/10251/#Comment_10251
Comment 21 soumya 2015-09-10 12:17:47 UTC
Hello dean.ellis, You have made the status fixed but the problem seems to be still exist