Bug 17866 - BookmarkXamarin extensions crash VS after installing productivity tools
Summary: BookmarkXamarin extensions crash VS after installing productivity tools
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.12.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: vsx
Depends on:
Reported: 2014-02-19 02:12 UTC by Rainer Mager
Modified: 2015-08-03 08:38 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Rainer Mager 2014-02-19 02:12:49 UTC
I recently tried installing the Microsoft Visual Studio 2013 Productivity Tools (http://blogs.msdn.com/b/visualstudio/archive/2013/12/19/productivity-power-tools-for-visual-studio-2013.aspx). After I did this I could no longer load my solutions that rely on Xamarin (i.e., iOS project) as VS would crash. If I open a non-iOS project then VS opened fine.

Even after uninstalling the productivity tools the problem still occurred until I also unstalled Xamarin. After that I was able to reinstall Xamarin and VS is happy again, although I don't have the productivity tools installed.
Comment 1 Ram Chandra 2014-02-26 03:21:37 UTC
I tried to reproduce this issue. but i am not able to reproduce this issue.

Steps to reproduce:

(1) Create an "iOS sample application" on Xamarin Studio. 
(2) Build and deploy "iOS application".
(3) Install "Microsoft Visual Studio 2013 Productivity Tools" on "Visual Studio 2013".
(4) Open "iOS sample application" on "visual studio 2013".
(5) Build and Deploy sample application on "Visual studio 2013".

Refer screencast : http://screencast.com/t/jijGxkHvA


windows 7 
Visual studio 2013
Xamarin.iOS :

Mac OS X Lion 10.7.5 
Xamarin Studio : 4.2.4 
Xamarin.iOS :
Comment 2 Rainer Mager 2014-02-28 09:45:01 UTC
Would you like a copy of my VS solution? It's about 30MB. I could also give you Git access to my repository if that's easier. If so can I work with someone directly to preserve confidentiality?
Comment 3 Ram Chandra 2015-08-03 06:39:40 UTC
I have tried to reproduce this issue with following build but I am not able to reproduce this.

Windows 8.1
Visual Studio Professional 2013
XVS: 3.11.666
Productivity Power Tools 2013

If you are still getting this behavior please feel free to reopen this issue and if it is possible please provide the sample project. So that we can reproduce this issue at our end.