Bug 17855 - Android designer crashing on simple UI
Summary: Android designer crashing on simple UI
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Designer ()
Version: 4.2.x
Hardware: PC Windows
: High major
Target Milestone: 4.2.3 (from master)
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2014-02-18 15:33 UTC by Andreas Fischer
Modified: 2014-02-26 19:31 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log files written by Xamarin during crashes. (77.49 KB, application/zip)
2014-02-18 15:33 UTC, Andreas Fischer
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andreas Fischer 2014-02-18 15:33:57 UTC
Created attachment 6084 [details]
Log files written by Xamarin during crashes.

Hi there,

I'm currently doing some first steps with Xamarin and have encountered a lot of crashes when working with the Android UI designer. I would provide you with some steps to reproduce the issue, but simply "using" the designer for more than a view minutes doing arbitrary things like add/delete controls will cause crashes of Xamarin Studio.

I have attached all log file of the last two hours, perhaps you can figure out what was happening.
Comment 1 Prashant manu 2014-02-19 01:58:54 UTC
Hi Andreas,

We have checked with adding/deleting controls and its working fine. Could you please specify the test steps for this issue?

Environment Info:
XS 4.2.2 (build 2)
Xam.Android 4.10.1-73

Thanks
Comment 2 Andreas Fischer 2014-02-20 14:58:49 UTC
Hi,

this is what causes crashes in almost every try:

- Create a new Android Layout
- Remove the default LinearLayout
- Add a TableLayout
- Remove the last column and row from the TableLayout.
- Stretch the first column
- Add a button to the upper right cell 
- Add a TextView to the upper left cell
- Add a SeekBar to the lower left cell

80% chance to crash Xamarin Studio on one of the last two steps. If it does not crash, just keep adding and removing controls to the TableLayout cells (SeekBar in my case).

Environment Info:
XS 4.2.3 (build 54)
Xam.Android: 4.12.0

I tried the stable releases at first. Due to the crashes I updated to the beta channel. The crashes still appear, and now I cannot downgrade to stable. This is no problem as "stable" does not count on my machine :)
Comment 3 Andreas Fischer 2014-02-20 15:00:19 UTC
If it does not crash, try reopening the layout or restarting XS. I get a crash almost every time trying to edit that layout file.
Comment 4 Lluis Sanchez 2014-02-21 03:14:32 UTC
This is very likely a duplicate of bug #17777. 

Can you please try this build?
https://dl.dropboxusercontent.com/u/492982/Xamarin%20Studio%204.2.3.59.msi
Comment 5 Andreas Fischer 2014-02-23 15:27:53 UTC
I was unable to reproduce the bug with this build. The designer also appears faster than in the previous build.

Thumbs up! I will reopen this or file in another bug if I encounter this problem again.
Comment 6 Rhet 2014-02-26 03:50:11 UTC
I have been encountering a lot of these errors.

1. I dragged a button into a view.
2. I moved and image next to a text.
3. I opened a layout file.
4. I adjusted the margin of a image on the left side.

This is only a few. His first statement is correct. just generally using the drag and drop function causes errors. I do however code the XML manually and have no errors thus far. Holding an element makes the application lag heavily. so its cause lies when the element is being held in state. Please look into it.

as for now, i use visual studio on the side to display the view to me. xamarin if a illogical layout is placed crashes the application. visual studio justpops up and says the element cant be put in Etc into Etc...