Bug 17753 - Linking - Breaks Application
Summary: Linking - Breaks Application
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.2.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Radek Doulik
Depends on:
Reported: 2014-02-13 12:09 UTC by Peter Farrell
Modified: 2017-06-27 15:52 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Peter Farrell 2014-02-13 12:09:18 UTC
I am only able to create a working release build with "No Linking" selected.

I have tried using both Link SDK assembly's only and Link All, when either of these options are selected my app crashes on run.
Comment 1 Mohit Kheterpal 2014-02-14 05:50:40 UTC
Today we have tried to reproduce this issue. But we are not able to reproduce it.

Could you please attached sample application so that we can reproduce this issue?
Comment 6 Saurabh 2014-10-31 02:14:38 UTC
I have checked this issue with attached sample and added class files and components. But I am experiencing different build errors. This is the build output for the same: https://gist.github.com/saurabh360/378a75610a4dd155c37e

X.S 5.5.3(Build 6)
Git revision: fbe3e9453daf6a3bb9a9709ed22bec35f7c9056b
XVS 3.7.248

@Peter, Are you still getting same Issue with latest stable builds?
Comment 7 Chris Hardy [MSFT] 2017-06-27 15:52:34 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!