Bug 17741 - Nothing happens when user tap on "https-WebRequest" option on physical device for "HttpClient" sample
Summary: Nothing happens when user tap on "https-WebRequest" option on physical device...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.12.x
Hardware: PC Windows
: High major
Target Milestone: 1.12 (Merge)
Assignee: Dominique Louis
Depends on:
Reported: 2014-02-13 04:44 UTC by Prashant manu
Modified: 2015-07-29 11:15 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

SampleApp (1.10 MB, application/octet-stream)
2014-02-19 07:39 UTC, Ram Chandra

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Prashant manu 2014-02-13 04:44:23 UTC
Steps to reproduce:
1.Open "HTTP Client" iOS sample in VS.
2.Debug or run the application
3.Click on "https-WebRequest" option.

Actual result:
Nothing happens when user tap on "https-WebRequest" option on an iOS Device.

Note:This issue is happening in VS with Device only while it is working fine with iOS simulator 6.0 and 6.1 and on XS it is working fine with both Device and simulator also.

Expected result:Appropriate page should be displayed when user tap on "https-WebRequest" option.

Supplement Info:
Debug Output:https://gist.github.com/saurabh360/f14ab394df657218cbc1
iOS Device log:https://gist.github.com/AkhileshKumar01/90dfb11594eeb89103d3
Mtb Server log:https://gist.github.com/AkhileshKumar01/a7894ffe5e00b315a786

Enviorment Info:
All windows
VS 2012/2013
XS for VS 1.12.214
iPhone 4S(6.1.3),iPOD iOS 6.1.3 iPhone 5C(7.1)
Xcode 5.0.1,5.0

App Info:monotouch-samples-master7e676561eb64d10e307f4e0cda97bfe9c605761b 

Regression Status:Regression,This was working fine with 1.10.39.
Comment 1 Jose Miguel Torres 2014-02-17 11:00:44 UTC
Hi Prashant,

This is working for me. Testing on iPad 6.1 with MTVS binaries from master and build 1.12.214. I am able to run either of the 4 options retrieving the stream response.

COuld you attach the project you are using or make sure it's updated from repo?

Comment 2 Dominique Louis 2014-02-18 10:18:53 UTC
AS per Jose's comment
Comment 3 Ram Chandra 2014-02-19 07:38:24 UTC
Today I have checked this issue with the following builds:

Environment Info:
All windows
VS 2012/2013
XS for VS 1.12.217
iPad 4(6.1.3),iPod (6.1.3) iPhone 5(6.0)

I am still seeing the same issue on tapping "Https-Webrequest" option.Below is the device log:https://gist.github.com/atin360/b91f8511e5028a3450e9

Please find the  attached sample app also.
Comment 4 Ram Chandra 2014-02-19 07:39:53 UTC
Created attachment 6087 [details]
Comment 5 Dominique Louis 2014-02-26 08:01:51 UTC
Hi Ram and PJ,
  I tried running the same app in Xamarin Studio and get the same result.

There is an exception being raised inside GmailDownloaded which is being swallowed up by the try catch.

The top level error is 

"Error getting response stream (ReadDone1): ReceiveFailure"

Inner Exception is : 

Attempting to JIT compile method '(wrapper delegate-begin-invoke) System.Func`4<byte[], int, int, int>:begin_invoke_IAsyncResult__this___T1_T2_T3_AsyncCallback_object (byte[],int,int,System.AsyncCallback,object)' while running with --aot-only. See http://docs.xamarin.com/ios/about/limitations for more information.

So this is not VS specific but may be run-time related.

Ram/PJ I'll leave it for you to re-assign.
Comment 6 Dominique Louis 2014-02-26 08:11:06 UTC
Change it's Release status too.
Comment 7 Dominique Louis 2014-02-26 11:26:06 UTC
After further investigation and another hour lost, it is as Jose pointed out, the one in MonoTouch-Samples works and the difference is that Ram's csproj did NOT have "Enable generic value type sharing" checked in the iOS Build->Advanced Tab.

So no need to re-assign this. It works. Marking it as invalid for now, unless it is supposed to work without the "Enable generic value type sharing" flag.
Comment 8 PJ 2014-02-26 20:21:58 UTC
Sorry Dominique. I ran the app with and without generic value type sharing here on both XS and VS as well, and it has matching behavior. Fails with generic value sharing off, succeeds with it on.

Ram, it was good of you to include the project in comment 3, but we really need to have you guys catch these discrepancies during the initial NEEDINFO request.

A simple 'git status' would be able to show you that there was a difference between the repo's version of the sample and your local copy.
Comment 9 Dominique Louis 2014-02-28 10:53:17 UTC
Further investigation shows that the final issue was that Enable Generic Value Type Sharing was not being persisted on the VS side. 

This PR in master

should fix the issue. PJ we need to decide if we want this fix in 1.12. Then it can be CPed into 1.12.

Comment 10 PJ 2014-02-28 12:46:40 UTC
Yes, let's get this into 1.12, that release hasn't gone back into testing yet and the bug here clearly can cause some confusion!
Comment 11 Dominique Louis 2014-03-03 07:52:06 UTC
Fix in this wrench build - https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=822&host_id=63&revision_id=260810
Comment 12 narayanp 2014-03-24 09:40:14 UTC
I have checked this issue with following builds:

Vs 2013/2012/2010
Xamarin for VS 1.12.247
X.iOS 7.2.1-63

Now all the options are working fine in iOS sample 'Http Client' on both devices and iOS Simulator. When I select any option and click on 'Issue HTTP Request', It display respective information.
Comment 13 Daniel Cazzulino 2015-07-29 11:15:16 UTC
Closing per last comment.