Bug 17569 - Unable to login into Android Facebook sample
Summary: Unable to login into Android Facebook sample
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.12.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Ben O'Halloran
Depends on:
Reported: 2014-02-03 09:58 UTC by narayanp
Modified: 2014-07-07 02:10 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description narayanp 2014-02-03 09:58:44 UTC
Steps to reproduce:
1. Open X.S
2. Open Facebook android application.
3. Debug the application.
4. Login with correct credentials.

Actual Result: User is not able to login into account on physical device. However, user is successfully able to login on Emulator(tried on API18)

Expected result: User should get logged into Facebook account on device.

Supplement info:
Application Output: https://gist.github.com/saurabh360/78f6a1b93302a9771048
Logcat: https://gist.github.com/saurabh360/f93480d86697bb630181

Environment details: 
All Mac
X.S 4.2.3(build 53)
Mono 3.2.6
X.Android 4.12.0-14

Device info:
Samsung S4 version 4.3

Regression Status:
We were not able to loging before as well. Reported Issues Bug 8497
Comment 1 Oleg Demchenko 2014-02-03 18:43:21 UTC
I was able to log in my facebook account with device.
Here's screenshot : http://screencast.com/t/Zt2mbzoeOD8x

Can you try to reproduce this issue with different devices/API's? Thanks!

Test Env: 
OS X 10.9.1
Xamarin Studio 4.2.3 (build 51)
Xamarin Android 4.10.2
Device info: 
Philips w732, Android 4.0.3
Comment 2 narayanp 2014-02-05 09:53:14 UTC
I am still not able to logged into Facebook account. I have tried on following devices:

Samsung Note version-2.3.6
Samsung S2 version 4.3
LG Nexus 4 version 4.4 

All Mac
X.S 4.2.3(build 54)
Mono 3.2.6
X.Android 4.12.0-22

monodroid sample-master/2c032103cc30ea8284d8df0c84f931fbf20e7c3e
Comment 3 Ben O'Halloran 2014-06-30 11:04:04 UTC
This seems to be the same as Bug 19643. This possibly explains why sometime this bug appears and sometimes it does not. From commit 2c032103cc30ea8284d8df0c84f931fbf20e7c3e, if compiled in release mode, the bug appears because the Internet permission is not requested in the Android Manifest. Adding in the permission resolves the issue.
When I did not add in the permission and I was in release mode I got the error. When I added in the permission everything ran correctly and works (tested posting a status, photo etc.)
@narayanp where you compiling in release or debug mode when you're getting these issues? I have a feeling that is a duplicate of Bug 19643.
My environment is X.S 5.0.1 X.Android 4.12.5
Comment 4 Saurabh 2014-07-07 02:10:35 UTC
I have checked this issue with latest sample and I am successfully able to
login into Facebook application in both  release and debug mode. I have tried it on below

Samsung Nexus 7 version 4.4.3
Samsung S2 version 2.3.3
Samsung Galaxy Note3 version 4.4.2

X.S 5.2 (Build 180)
Git revision: c27cfff0160e6f3d8ad82b57be030d6adf866743

Hence, closing this issue.