Bug 17509 - Cannot open ANY files in Xamarin Studio
Summary: Cannot open ANY files in Xamarin Studio
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.2.x
Hardware: PC Windows
: Normal normal
Target Milestone: 4.2.4 (from master)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2014-01-30 09:53 UTC by theartwebreathe
Modified: 2014-02-12 06:23 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description theartwebreathe 2014-01-30 09:53:20 UTC
I just installed Xamarin Studio and I was trying to go through the Tasky tutorial. I was able to Debug the app as-is on my Android device, but then, I tried opening Task.cs, and got an error. I then tried opening other files, and got the same error. I then tried creating a new solution and creating a .cs file. Same error. Here's the error:

The file 'C:\Users\kcloutier\Documents\Xamarin\Tasky\AndroidStarter\Tasky.Core\Task.cs' could not be opened. The type initializer for 'MonoDevelop.SourceEditor.SourceEditorView' threw an exception.

System.TypeInitializationException: The type initializer for 'MonoDevelop.SourceEditor.SourceEditorView' threw an exception. ---> System.TypeInitializationException: The type initializer for 'CopyOperation' threw an exception. ---> System.NullReferenceException: Object reference not set to an instance of an object.
 at Mono.TextEditor.ClipboardActions.CopyOperation..cctor()
 --- End of inner exception stack trace ---
 at Mono.TextEditor.ClipboardActions.CopyOperation.add_Copy(CopyDelegate value)
 at MonoDevelop.SourceEditor.SourceEditorView.cctor()
 -- End of inner exception stack trace ---
 at MonoDevelop.SourceEditor.SourceEditorView.cctor()
 at MonoDevelop.SourceEditor.SourceEditorDisplayBinding.CreateContent(FilePath filename, String mimeType, Project ownerProject)
 at MonoDevelop.Ide.Gui.LoadFileWrapper.Invoke(String fileName)
Comment 1 theartwebreathe 2014-01-30 10:19:09 UTC
After a reboot, this problem is resolved, sorry for any inconvenience.
Comment 2 Mikayla Hutchinson [MSFT] 2014-01-30 18:29:59 UTC
No worries, thanks for reporting it. I took a look at the code and I can't see anything obvious so it might have been some kind of one-off memory corruption or system issue. Please let us know if it happens again!
Comment 3 Atin 2014-02-12 06:23:48 UTC
Today, we have checked this issue with:

XS 4.2.4(build17)- 00b6aafbd9d5b59499aa5f9e7ba274f55ed95d5d
Xamarin addins: 2debf1c1984b1d3d8312decda84dc966b7412433
Windows 8
MFA 4.12.0.22

We are not able to reproduce this issue. We are successfully able to open .cs file of Android sample without any error.

Hence marking this as verified