Bug 17454 - NUnit [Explicit] not honored
Summary: NUnit [Explicit] not honored
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: 4.2.4 (from master)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2014-01-28 02:24 UTC by Miha Valencic
Modified: 2015-06-17 23:36 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Miha Valencic 2014-01-28 02:24:20 UTC
[Filing a bug as per: http://forums.xamarin.com/discussion/comment/41918]

I have some tests that require certain network services to be available. Naturally, I don't want those tests to be run when I run the whole suite.

When I run tests from Xamarin Studio (Unit testing pad, right click the top namespace, run), those tests get run. Is there a way to tell XS not to run those tests when I run the whole test project?

This is true for test methods marked with [Explicit] as well as for test fixtures, marked with [Explicit].
Comment 1 Miha Valencic 2014-01-28 02:25:12 UTC
BTW, The version if XS is 4.3.1 build 5.
Comment 2 Mike Krüger 2014-01-28 03:21:26 UTC
fixed
Comment 3 Miha Valencic 2014-01-28 03:22:16 UTC
That was FAST! :)
Comment 4 Mike Krüger 2014-01-28 03:55:10 UTC
Unfortunately it'll take some time until that gets released :/
Comment 5 Sadik Ali 2014-02-13 03:07:23 UTC
I have verified this issue on below environment:

All Mac
Xamarin Studio 4.2.4 (build 17)
Build Information
Release ID: 402040017
Git revision: 00b6aafbd9d5b59499aa5f9e7ba274f55ed95d5d
Xamarin addins: 2debf1c1984b1d3d8312decda84dc966b7412433

I followed below steps to verify:

1. Created Nunit library project.
2. Added two unit test method.
3. Apply "Explicit" on one of test method.
4. Executed Nunit test project and observed that "Explicit" test method not executed automatically. 

Refer screen shot: http://www.screencast.com/t/3dupLCEY
Comment 6 Kevin Cuzner 2015-06-17 23:36:55 UTC
Xamarin Studio 5.9.3 does seem not honor Explicit attributes on Fixtures.

It does honor Explicit attributes on Methods, per the original fix.