Bug 17440 - Debug.WriteLine is not recognized as formatting method
Summary: Debug.WriteLine is not recognized as formatting method
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2014-01-27 05:56 UTC by Marek Safar
Modified: 2014-01-27 11:33 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Marek Safar 2014-01-27 05:56:06 UTC

    
Comment 1 Mike Krüger 2014-01-27 08:27:12 UTC
Works for me.

What do you mean with 'not recognized as formatting method' ? Maybe we're speaking of different things.
Comment 2 Marek Safar 2014-01-27 10:20:42 UTC
It does not mark {0} red
Comment 3 Mike Krüger 2014-01-27 11:00:38 UTC
Works for me - are you really using master ?
I can remember that you opened a similiar bug not so long ago which got fixed - it may not yet been released.
Comment 4 Mike Krüger 2014-01-27 11:01:43 UTC
btw. if you built from source ensure that the submodules are up to date

git submodule update --recursive
Comment 5 Marek Safar 2014-01-27 11:02:33 UTC
I am running Version 4.2.3 (build 138) but using the code in MonoTouch project if it makes difference to XS
Comment 6 Mike Krüger 2014-01-27 11:13:31 UTC
looks like that http://screencast.com/t/591rPp2FI5d  for me.
Comment 7 Marek Safar 2014-01-27 11:24:33 UTC
Aha, I found it.

Debug.WriteLine ("test {0}", "x");

It'd be useful to get some sort of warning for such case
Comment 8 Mike Krüger 2014-01-27 11:31:49 UTC
ah k - now I understand the issue - the warning in that case is the missing coloring :)
Comment 9 Marek Safar 2014-01-27 11:33:31 UTC
Yep, the red was not the best colour chosen ;-)