Bug 17405 - XS crashes when moving a pinned value and the debugger ends
Summary: XS crashes when moving a pinned value and the debugger ends
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 4.3.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-01-23 20:14 UTC by Stephen Shaw
Modified: 2014-03-26 13:40 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Stephen Shaw 2014-01-23 20:14:55 UTC
I pinned a value while debugging an iOS app. I was moving it when the debugger ended (8 second iOS app startup limit) and crashed leaving visual artifacts(?) on the screen.

Here is the gist with the kill -QUIT output -> https://gist.github.com/decriptor/8590278
Comment 1 Jeffrey Stedfast 2014-02-06 14:43:39 UTC
This *may* be fixed now.

The old code would re-query the debugger every pixel the tooltip was dragged, but it no longer does that at all.
Comment 2 Jeffrey Stedfast 2014-03-13 16:12:36 UTC
Gonna call this one fixed
Comment 3 Saurabh 2014-03-26 13:40:09 UTC
I have checked this issue with latest master builds.

I pinned a value while debugging an iOS app. After debugger ended, the pinned value disappear but XS does not crash.
Screencast: 
http://screencast.com/t/dJ8hnyiUI9vf

I pinned a value while debugging an iOS app. While debugger is connected, the pinned value, we are able to move pinned value and XS does not crash.
http://screencast.com/t/kJVO60Wjb

Master Builds info:
Xamarin Studio
Version 4.2.4 (build 266)

Build Information
Release ID: 402040266
Git revision: 57fa6b7639703775ae1d5c46536e42ab424cb177
Build date: 2014-03-20 12:34:27-04
Xamarin addins: eee141c29724a19529e77b8e743086d95b29f5ba

Apple Developer Tools
Xcode 5.1 (5084)
Build 5B130a

Xamarin.iOS
Version: 7.2.2.14 (Enterprise Edition)
Hash: 16bef0b

Device info: iPod iOS 6.1.5


As of now, I am closing this issue.

Please, let me know if I have to check anything else to verify this issue.