Bug 17305 - iOS Simulator 6 crashes in debug when no linking set
Summary: iOS Simulator 6 crashes in debug when no linking set
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 7.0.5.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2014-01-17 19:03 UTC by Ian
Modified: 2014-01-20 09:58 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ian 2014-01-17 19:03:02 UTC
All my apps.

Debug to Simulator or device, ios7 or ios5 works fine.

Debug to iOS Simulator 6 it crashes 100% after splash screen. No logs, no messages, nadda.

To make it work I set the "Debug build to Link SDK assemblies only" for Debug iPhoneSimulator (iOS 6 only)

I do not have an iOS 6 device to test on.

Strange huh. 

Xamarin Studio
Version 4.2.2 (build 2)
	Mono 3.2.5 ((no/964e8f0)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (
	Package version: 302050000

Apple Developer Tools
Xcode 5.0.2 (3335.32)
Build 5A3005
Comment 1 Sebastien Pouliot 2014-01-18 10:55:23 UTC
That's weird. It looks like the pre-built simlauncher is not happy (doing a "Link SDK" will rebuild the launcher). You can also do this, without linking, by adding "--nofastsim" to your addition mtouch arguments.

DId you close the simulator (to have it automatically re-started by XS) ?

Did you try doing a reset ? i.e. menu "iOS Simulator" then "Reset Content and Settings…" just in case there's some stale files that could be the issue.

Also you can get a crash report (for the simulator and/or the apps running inside it) using OSX Console.app. That might tell us what is the issue (attach them to the bug report).

A full build log might be useful too (with the extra '-v -v -v -v') to see if any warning were reported.

Finally it would be better to use XS to get the version informaiton (e.g. above is missing the iOS version). Mavericks has some weird simulator issues (but it's likely not the case since it does not run iOS5 like you did).
Comment 2 Ian 2014-01-18 11:25:19 UTC
Ill get that info for you.

I have the newest everything, release branch, OS etc.

I tried a reboot, and a reset of the simulator and a clean of solutions. Seems universally happening, all apps, all types.

=== Xamarin Studio ===

Version 4.2.2 (build 2)
Installation UUID: 501ceb77-86bf-470c-837e-d49442547207
	Mono 3.2.5 ((no/964e8f0)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (
	Package version: 302050000

=== Apple Developer Tools ===

Xcode 4.6.3 (2068)
Build 4H1503

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Xamarin.Android ===

Version: 4.10.1 (Enterprise Edition)
Android SDK: /Users/vink/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: 9c42159
Build date: 2013-02-12 20:04:08-0500

=== Build Information ===

Release ID: 402020002
Git revision: c5f82958ae7d9af652b44b87ceff777b3ad19b91
Build date: 2013-11-19 15:35:40+0000
Xamarin addins: a4044fee09138f6fd031a9944b7caaeb51e57e80

=== Operating System ===

Mac OS X 10.9.1
Darwin Vink17.local 13.0.0 Darwin Kernel Version 13.0.0
    Thu Sep 19 22:22:27 PDT 2013
    root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
Comment 3 Ian 2014-01-18 11:27:10 UTC
How do I get a crash report from "OSX Console.app" Not familiar with that app.

Not that the Application Output window in XS just says "Application terminated" no details. I tried putting a break point at line 1 of the apps, but never gets there.
Comment 4 Sebastien Pouliot 2014-01-18 11:35:41 UTC
I"m confused. You seem to be using Mavericks but the iOS5 simulator does not work on it. I assume it was an iOS5 *device* right ?

Also XS seems to be using Xcode 4.6 (not the XS 5.0.2 you mentioned before). You might want to try again with XS using this version of Xcode.

For Console.app:

* Open Console.app;
* Select "All Messages" in the "SYSTEM LOG QUERIES" (left);
* Scroll to the end and go up until you find your application name (or iOS Simulator);
* You should see an "expand" button (triangle) and when expended you should have a link to "Open crash report"
* That will jump to the crash report

You might also see it under "User Diagnostics Reports" (left) as a .crash file named with your process name and the date/time.
Comment 5 Ian 2014-01-18 11:51:10 UTC
XCode 4??

I have Xcode 5 installed and the XS Preferences says "SDK Found at Default Location".

I'll try manually setting the app to point to Applications/Xcode
Comment 6 Ian 2014-01-18 11:55:25 UTC
That did it.

I forced XS to point to the xcode.app and it works fine now.

I have xcode 4 installed for old apps but I guess no longer need it given the 1 feb mandate by Apple.

Perhaps XS is looking for the lowest Xcode installed, or the last one installed?

Problem closed, but interesting feature learned.
Comment 7 Sebastien Pouliot 2014-01-18 12:21:51 UTC
Great, glad you get it working!

AFAIK XS will, by default, look for:

(a) /Application/Xcode.app/...
(b) /Developer/Xcode/...

where (b) is for pre-app store Xcode (4.2 and earlier) - and that _might_ have been removed in recent XS versions.

If you installed more than one version of Xcode then I assume 4.6 was the one named Xcode.app.
Comment 8 Akhilesh kumar 2014-01-20 09:58:36 UTC
As per Ian's comment 6, issue is resolved.

Hence closing this issue, marking status as verified.