Bug 17186 - App doesn't get rebuilt - need to clean and rebuild
Summary: App doesn't get rebuilt - need to clean and rebuild
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: vsx
Depends on:
Reported: 2014-01-11 08:08 UTC by Andy
Modified: 2014-07-18 07:41 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andy 2014-01-11 08:08:12 UTC
Using VS 2013
VS iOS 1.8.63

Plugin doesn't understand that code has been changed. I need to clean/rebuild to push changes

Solution->Properties->Build is ok (selected)
Comment 1 Mohit Kheterpal 2014-01-13 08:14:32 UTC
Today we have tried to reproduce this issue but we are unable to reproduce.

We have tried it via following steps :
1. Create an iOS Project in VS
2. Deploy it on simulator
3. Stop debugging
4. Make changes in MyViewController.cs file
5. Save changes (Ctrl + S)
6. Again debug on simulator

Then observed that it display the changes on simulator made in MyViewController.cs file. 

Could you please correct our steps, if we have followed wrong steps to reproduce this issue?
Comment 2 Andy 2014-01-13 08:40:40 UTC
I would really like to know what's different, this never happened before.

The only thing that I recently changed is to use VS2013 and move all files to local PC hard disk instead of them being on the Mac. Funny that on the Mac the opposite happens: it always rebuilds even if it's not changed.

Since I have no repro steps beyond that, I have no idea. It doesn't happen very often
Comment 3 Marek Habersack 2014-01-13 08:53:05 UTC

The plugin doesn't involve itself in detecting code changes. It's all in the hands of VS - it's the IDE which performs the managed build. The extension kicks in only when deployment is requested *after* the managed build is done.

Clean your project directory througly - remove all the bin/, obj/ directories, get rid of all the *.suo files
Comment 4 Andy 2014-02-03 08:19:52 UTC
Done, no change