Bug 17122 - The "exists" function only accepts a scalar value, error when building Application project with Play Services Component
Summary: The "exists" function only accepts a scalar value, error when building Applic...
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.12.0
Hardware: PC Windows
: Normal normal
Target Milestone: 4.12.0 (KitKat)
Assignee: Radek Doulik
Depends on:
Reported: 2014-01-08 12:08 UTC by Tomasz Cielecki
Modified: 2014-02-06 05:47 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Tomasz Cielecki 2014-01-08 12:08:00 UTC
The folloing error appears when building an Application with the Google Play Services (Gingerbread) component added.

    Error	1	The "exists" function only accepts a scalar value, but its argument "@(_AdditionalAndroidResourceManifests)" evaluates to "C:\Users\Tomasz\Documents\Visual Studio 2013\Projects\AppCompat\Components\googleplayservicesgingerbread-13.0\lib\android\13\content\google-play-services/libproject/google-play-services_lib\AndroidManifest.xml;C:\Users\Tomasz\Documents\Visual Studio 2013\Projects\AppCompat\Components\googleplayservicesgingerbread-13.0\lib\android\18\content\support/v7/appcompat\AndroidManifest.xml" which is not a scalar value.

I am running Xamarin.Android 4.11.00217 (c789d807) and it happens in either VS2012, VS2013 or XS (tried both 4.1.1 and 4.2.2).

It can be replicated by creating a new Android Application project, then simply adding the Google Play Services component to the project. I have verified the error on two different machines with the same result.

Just like reported here: http://forums.xamarin.com/discussion/12030/error-building-project-with-play-services-component it strikes me that the paths have mixed forward and backward slashes. This should however not be a problem in Windows where the file system ignores it, however it could be a problem on unix type filesystems.
Comment 1 michele.scandura 2014-01-10 09:53:34 UTC
I'm having the same issue with an app with the following settings:
- Compile using API Level 15
- Minimum Android to target Level 8
- Target Android version use compile using SDK version.

I'm using Support.V4, SUpport.v7.AppCompat.
Any Play Services component will trigger the issue.
Comment 2 Radek Doulik 2014-02-03 13:24:29 UTC
Works OK for me with 4.12-series build, I believe it was fixed by commit 58522ad69ba280a0fbb4a0734daef14e59bfd3cd in 4.12-series branch.
Comment 3 narayanp 2014-02-06 05:47:18 UTC
I have checked this issue with following builds:

All Windows
X.S 4.2.3(build 54)
VS 2013/2012

To check this issue I have created an Android template application and then added 'Google Play Services' component in this project. When I build the project, it is giving me two build errors. This is the gist for the same: https://gist.github.com/saurabh360/db40dd9824db55a0e7d5

I am not sure am I missing any step over here. Please let me know is it correct or not?