Bug 17063 - Solution/Project doesn't remember simulator target
Summary: Solution/Project doesn't remember simulator target
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 1.8.x
Hardware: PC Windows
: Low enhancement
Target Milestone: ---
Assignee: vsx
Depends on:
Reported: 2014-01-05 16:04 UTC by Andy
Modified: 2016-05-10 17:03 UTC (History)
11 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andy 2014-01-05 16:04:53 UTC
Defaults to iOS 6.1 every time the solution is loaded

Also, but this is already reported, I think, there's no way to select 4" retina
Comment 1 Akhilesh kumar 2014-01-07 06:30:56 UTC
Today we have tried to reproduce this issue. But we are not able to reproduce it.

We have tried following steps to reproduce it :
1. Create Sample iOS project
2. select any Simulator(not default)
3. Run application on Simulator
4. Stop application and quite XS
5. Again open XS and open the same sample application

Observed that, XS loads project with previously selected simulator. 

Screencast : http://screencast.com/t/gnVQez1Fp8f

We have checked it with XS 4.2.3 (build 24) and Xcode 5.0.1

Could please check that, we have followed correct steps to reproduce this issue? If not, please correct our steps to reproduce this issue.

Note : As per bug 10500, when we create new iOS application then latest version of simulator is available as default Simulator.
Comment 2 Andy 2014-01-07 06:39:53 UTC
XS ? I filed this under VS extension !
Comment 3 Akhilesh kumar 2014-01-07 08:27:11 UTC
@Andy, Sorry for the confusion.

We are also getting same issue with VS via following steps :
1. Create Sample iOS project
2. select any Simulator(not default)
3. Run application on Simulator
4. Stop application and quite VS
5. Again open VS and open the same sample application

Observed that : The default simulator(oldest) is shown in VS to deploy application on mac.

Screencast : http://screencast.com/t/hDq0VIKiP
Comment 4 Akhilesh kumar 2015-07-27 10:15:57 UTC
I have checked this issue with latest stable XVS 3.11.666 and it seems that now this issue has been fixed.

Now VS remembers the Solution/Project's simulator on which it was deployed previously and on reopening same Solution/Project it select that simulator in device dropdown.

Screencast: http://screencast.com/t/CLAWDNYSPst

Hence closing this issue.

Feel free to reopen it, if anyone still facing this issue.

Microsoft Visual Studio Ultimate 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00080

Xamarin   3.11.666.0 (ebae43a)
Xamarin.Android (5f55a9ef61c11b6ce0890bc91e4c71b1b92be214)
Xamarin.iOS (67b390d0d1bd741582cf7b7fd3ffea08583a3f83)