Bug 16930 - Unable to install latest packages to VS 2013
Summary: Unable to install latest packages to VS 2013
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: 1.10.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Dominique Louis
Depends on:
Reported: 2013-12-21 22:28 UTC by Thom
Modified: 2014-01-02 08:29 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Lates installation log (15.64 KB, text/plain)
2013-12-24 09:22 UTC, Thom
Prior Installation Log (12.93 KB, text/plain)
2013-12-24 09:23 UTC, Thom
Older Installation Log (40.79 KB, text/plain)
2013-12-24 09:24 UTC, Thom
Original Installation Log (14.95 KB, text/plain)
2013-12-24 09:24 UTC, Thom

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Thom 2013-12-21 22:28:35 UTC
I have both VS 2012 and VS 2013 installed on my PC. When I run the installation it installs to VS 2012, and not to VS 2013. I need to install to either both platforms, or just VS 2013.
Comment 1 Mohit Kheterpal 2013-12-23 06:19:51 UTC
Today we have tried to reproduce this issue, but we are able to use Xamarin extensions in VS 2012 and VS 2013 on same PC.

Could you please provide us build information? So that we can reproduce this issue.
Comment 2 Thom 2013-12-24 09:22:59 UTC
Created attachment 5722 [details]
Lates installation log
Comment 3 Thom 2013-12-24 09:23:29 UTC
Created attachment 5723 [details]
Prior Installation Log
Comment 4 Thom 2013-12-24 09:24:16 UTC
Created attachment 5724 [details]
Older Installation Log
Comment 5 Thom 2013-12-24 09:24:43 UTC
Created attachment 5725 [details]
Original Installation Log
Comment 6 Marek Habersack 2014-01-02 06:14:11 UTC
You are installing the extensions using the unified installer which will download and install the 1.8 version (the latest stable) of the extension. To support VS2013 you need to install Xamarin.iOS for VS 1.10 from the beta channel.
Comment 7 Mohit Kheterpal 2014-01-02 08:29:34 UTC
As per comment 6, this is a feature.

Hence closing this issue.