Bug 16886 - Xamarin Studio crashes when going into Developer Accounts
Summary: Xamarin Studio crashes when going into Developer Accounts
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: 4.2.4 (from master)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-12-18 17:52 UTC by NeoDarque
Modified: 2014-02-10 16:29 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
XamarinStudio log (49.02 KB, application/octet-stream)
2013-12-18 17:59 UTC, NeoDarque
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description NeoDarque 2013-12-18 17:52:43 UTC
I start Xamarin Studio, open the preferences, select "Developer Accounts", then after a few seconds Xamarin Studio crashes. Reproducible every time. Since there is a gap of a few seconds before the crash I've tried deleting my two developer accounts, but xamarin studio crashes after removing the account (and it has in fact never been removed one can see on the next launch).

I've tried removing and re-adding the accounts using Xcode in case there was something wrong with the accounts but to no avail.

This is using Build 4.3.0, but I've had the same problems in the 4.2.x series too. 

This is reproducible on both my machines so it's most likely not a local corruption of data somehow.

Could it somehow be connected with the fact that both my developer accounts are connected to more than 1 team? And Xamarin Studio doesn't handle that?

How can I provide more info?

Cheers,
Ted
Comment 1 NeoDarque 2013-12-18 17:59:45 UTC
Created attachment 5697 [details]
XamarinStudio log

This is the contents of XamarinStudio's log during a session where I simply launch XamarinStudio, open preferences and select the "DeveloperAccounts" tab and nothing more.
Comment 2 Jeffrey Stedfast 2013-12-18 21:06:59 UTC
already fixed in the upcoming 4.2.3
Comment 3 Saurabh 2014-01-17 08:16:33 UTC
I have checked this issue with following builds:

X.S 4.2.3(build 127)

Now, after navigating to Xamarin Studio->Preferences->Developer Accounts, I am able to delete developer account and also able to add developer account for XS.

After going into Developer Accounts, I waited 2 minutes but XS does not crash.

Screencast: http://screencast.com/t/soo0yn9ZojeU

Hence, closing this issue.