Bug 16830 - [iOS]BCL System.Xml test, TestSerializeSchema failure in QA monotouch-master lanes
Summary: [iOS]BCL System.Xml test, TestSerializeSchema failure in QA monotouch-master ...
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 7.0.4.x
Hardware: PC Mac OS
: --- normal
Target Milestone: 7.2.1
Assignee: Zoltan Varga
Depends on:
Reported: 2013-12-16 18:35 UTC by GouriKumari
Modified: 2014-03-12 17:54 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description GouriKumari 2013-12-16 18:35:43 UTC
Steps to reproduce:
Update System with monotouch-master 383500af1eb21271ed004170e220ceac94e1c7ef 
Update corresponding mono and maccore
Execute bcltest System.Xml

Actual Behaviour:
TestSerializeSchema failed on iPhone 5.0.1, iPad 6.0.1, iPhone5S, iPhone5, iPodTouch5gen


Supplemental Info:
In QA Lane, last build in which test passed is 19953c66d13797cf9a2693a573b5e1ef73c33580

Comment 1 Sebastien Pouliot 2013-12-17 08:42:29 UTC
Does it happen on 7.0.6 or 7.1.x ? or only master ?

If the later then the milestone is incorrect.
Comment 2 Sebastien Pouliot 2013-12-17 09:31:28 UTC
The important revision is when it starts (the next one after when it worked earlier)

-	$ cd mono && git reset --hard c3bcbb87c8b75295b3fec3fe97baa30918e7afa9
+	$ cd mono && git reset --hard f6e4c12036e62d52df6884721d9c8f76dcd95bfe


That means mono c3bcbb87c8b75295b3fec3fe97baa30918e7afa9 was correct
while f6e4c12036e62d52df6884721d9c8f76dcd95bfe is not.

Also if that does not happen on mono/monotouch-7.0.6-branch it means its not related to stuff that was backported. That should limit the number of commits that could produce the regression.
Comment 3 Sebastien Pouliot 2013-12-17 09:49:04 UTC
* It works in 7.1.x branch (so what was backported, e.g. PCL/RX fixes, are not the issue);

* It works on master on the simulator (with or without using the linker);

* It fails (on master) for device builds (even if linking is disabled);

* There's no System.Xml related commits between the above revisions;

That's likely a runtime/aot regression, c.c. Zoltan.

Note: it's not a blocker for 7.2 (as long as we don't bump mono)
Comment 4 GouriKumari 2013-12-17 10:41:24 UTC
The issue happens in Xamarin.iOS master builds. There is no 'master' target milestone set in bugzilla, so I wasn't sure about where to assign it.
Comment 5 Zoltan Varga 2014-01-03 08:50:41 UTC
Fixed in mono master 0a558a7af643d8f622aca03c67b589f7ce27798f/mt master 3c066dda8b45e250858303e30d04205d0455da94.
Comment 6 Atin 2014-01-30 06:07:04 UTC
Today, we have tried to verify this issue but we are not sure about the steps, could you please provide sample test case so we can verify this issue?
Comment 7 Zoltan Varga 2014-01-30 10:32:41 UTC
The problem happened when running a test suite, it doesn't happen any more, so I think this can be set to VERIFIED.
Comment 8 GouriKumari 2014-01-30 11:53:51 UTC
System.Xml tests are now passing in QA monotouch-master builds. Therefore, marking this bug as verified fixed.

iPad 6.0 https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1947894
iphone4, 5.0.1 https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1939618

Test Env:
monotouch-master: cfa39272cf772d27c6153fd58085e4f720ade2ae
iPad 6.0, iPhone4 5.0.1