Bug 16629 - [iOS]BCLTest ServiceDescriptionTest failures observed on device in QA monotouch-master lanes
Summary: [iOS]BCLTest ServiceDescriptionTest failures observed on device in QA monotou...
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 7.0.4.x
Hardware: PC Mac OS
: --- normal
Target Milestone: 7.2.0 (iOS 7.1)
Assignee: Sebastien Pouliot
Depends on:
Reported: 2013-12-05 18:07 UTC by GouriKumari
Modified: 2013-12-09 16:26 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description GouriKumari 2013-12-05 18:07:56 UTC
Steps to Reproduce:

Install monotouch master 242f7cd552f88de64ed4416915623f4113e25d1e and corresponding mono
Execute BCLTest System.Web.Services

Actual Result:
7 ServiceDescriptionTests fail on device

This failure is observed in Mavericks, MountainLion and Lion
Devices: iPhone 5S 7.0.2, iPad6.0.1, iphone4 5.0.1

The latest QA wrench build on which the error started occuring is: ea9fcc532f2b971a1604118654189eb3854bd350 


iPhone5.0.1: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1790601
iPhone5S: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1790659
iPad6.0.1: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1790778
Comment 1 Sebastien Pouliot 2013-12-06 08:55:03 UTC
OTOH there's no recent changes in this assembly (or it's test suite). When was the last time this worked (on device) ? e.g. did it worked while testing 7.0.4?

It looks like some type(s) might be missing (which is possible since device builds are linked). The above info will let me know where (or when) to look.
Comment 2 GouriKumari 2013-12-06 11:35:35 UTC
I couldn't find any System.Web.Services failure on 7.0.4 or 7.0.5 QA lanes.  The latest QA wrench builds which passed the test and test logs are listed below:

Xamarin.iOS 7.0.4 : 023207be45e1d3aae50aca8a85387ababa633bb2
iPhone4, 5.0.1
Test Log: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1784863
iPad2, 6.0.1
TestLog: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1785569

Xamarin.iOS7.0.5 : e57ab6445f1bdda539f0fe7833da89da4b86f29d 
iPhone4, 5.0.1

iPad2 6.0.1
TestLog: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1792271

Comment 3 GouriKumari 2013-12-06 11:39:24 UTC
Updates to the above comment:
I linked the wrong tests for some of the devices in comment #2. Please find the correct ones here:

Xamarin.iOS 7.0.4 : 023207be45e1d3aae50aca8a85387ababa633bb2
iPhone4, 5.0.2

Xamarin.iOS7.0.5 : e57ab6445f1bdda539f0fe7833da89da4b86f29d
iPad2 6.0.1
TestLog: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1792293
Comment 4 Sebastien Pouliot 2013-12-06 14:55:03 UTC
Thanks for checking this - it reduce the possibilities :-)
Comment 5 Sebastien Pouliot 2013-12-06 17:37:38 UTC
Fixed in master c4811efd032ea9d95121a410891130fdf3f83dc7
Comment 6 GouriKumari 2013-12-08 18:22:36 UTC
ServiceDescriptionTests didn't pass in c4811efd032ea9d95121a410891130fdf3f83dc7. Could you take a look at it again?

Tests Log:

iPhone5.0.1: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1797636
iPhone 5S:: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1797638
iPad6.0.1:  https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1797793
Comment 7 Sebastien Pouliot 2013-12-09 10:48:00 UTC
oops, rebuilding XI recreates the project files - and I lost my settings :(

Fixed in master 3443fc39b180825a309dc5db489a2938dfdc9c6b
Comment 8 GouriKumari 2013-12-09 16:26:50 UTC
ServiceDescriptionTests passed in 3443fc39b180825a309dc5db489a2938dfdc9c6b. Marking bug as verified fixed.

Test Logs:
iPhone5.0.1 : https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1801185
iPhone5S: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1801185
iPad6.0.1: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=1801260