Bug 16627 - VS2010 Ultimate crashes when loading iOS solution if no build host
Summary: VS2010 Ultimate crashes when loading iOS solution if no build host
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Windows
: High major
Target Milestone: 3.1
Assignee: Jose Miguel Torres
Depends on:
Reported: 2013-12-05 17:35 UTC by Richard Urwin
Modified: 2015-01-05 11:20 UTC (History)
12 users (show)

Is this bug a regression?: ---
Last known good build:

Screenshot of Visual Studio crash (141.21 KB, image/jpeg)
2013-12-13 02:21 UTC, Richard Urwin

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Richard Urwin 2013-12-05 17:35:02 UTC
Each time I try to load an iOS solution, VS2010 Ultimate crashes  if it can’t find the Mac build host.

On loading the solution, when the Mac build host window is displayed, I’ve tried pressing:

-	Cancel
-	Continue -> Close
-	Continue -> Configure Host Manually (then enter an IP, e.g.

It happens on two different computers on different networks, so I suspect it’s a common problem.

The following lines entries are made in the Trace.0.log file (located in: AppData\Local\Xamarin\Log\MonoTouchVS\10.0)

Mono.Android.VisualStudio.MonoAndroidPackage Warning: 0 : [2013-12-05 21:24:47.8] Initializing Mono.Android.VisualStudio.MonoAndroidPackage
Mono.IOS.VisualStudio.MonoTouchPackage Error: 0 : [2013-12-05 21:51:27.5] Build server control connection failed
Mono.IOS.VisualStudio.MonoTouchPackage Error: 0 : [2013-12-05 21:51:27.5] Not connected to the build server

No entries are made to the ActivityLog.xml (located in: AppData\Roaming\Microsoft\VisualStudio\10.0)

This is not a dupe of 12333 because it only started happening with the latest Xamarin.iOS update which introduced the new pairing mechanism.
Comment 1 Dave Thomas 2013-12-10 06:17:22 UTC
I cannot replicate this issue.  I just tried opening a HelloWorld iOS application in visual studio 2010 Ultimate with the build host disconnected, following the steps above, and I can't find any issues with VS2010 crashing.  

Which version of the Visual Studio Extensions are you using?  
What other extensions are you using in Visual Studio?  

Are you running Visual Studio in logging mode, as logging is disabled by default.  From the command prompt type:  devenv /log

This should hopefully write to the log file, could you also attach the log file after the crash?  

Comment 2 Richard Urwin 2013-12-13 02:21:32 UTC
Created attachment 5655 [details]
Screenshot of Visual Studio crash
Comment 3 Richard Urwin 2013-12-13 02:23:06 UTC
We just moved over to a new buld server and this no longer happens, however it still happens on my development computer. Screenshot attached. 

I'm no longer prompted for a Mac build host though - VS2010 just crashes almost as soon as I open the solution (as you can see from the screenshot).
Comment 4 Jose Miguel Torres 2014-05-20 08:03:14 UTC
Hi Richard, can you confirm this is still happening with the latest version?
Comment 5 Richard Urwin 2014-05-20 09:40:12 UTC
Hi Jose,

I have the latest version and I can't replicate the problem now. It could either be because you've fixed it, or possibly because I've previously connected it successfully once before (I now have a Mac on the network which I've been using).

So now, even when the Mac is switched off, I only get an error message:

Error	1	Connection to Xamarin.iOS Build Host failed. Double click here to attempt to reconnect/select a server.	Xamarin.iOS Extension	0	0

In order to replicate and determine whether you've definitely fixed it, you'd need try opening an iOS project on an instance of VS2010 that has never been connected before.
Comment 6 Jose Miguel Torres 2014-05-20 09:46:50 UTC
Hi Richard,

Thank you very much for your feedback. Turning this bug to InProgress state in order to check that everything has been fixed.

Comment 7 Jose Miguel Torres 2014-05-20 10:26:15 UTC
Tested with Xamarin.iOS 2.00.110 on clean install VS2010 instance and working right. Hence closing this bug.
Comment 8 Mohit Kheterpal 2014-06-09 11:23:23 UTC
I have checked this issue with Fresh VM of windows 7 with VS 2010 installed only. 

This is working fine with Xamarin 3.1.187 and with X.iOS

Hence, closing this issue.