Bug 16540 - Add-In not loading anymore after SDK update in VS 2013
Summary: Add-In not loading anymore after SDK update in VS 2013
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Visual Studio Compatibility ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-12-02 04:16 UTC by Berndt H.
Modified: 2017-05-10 23:33 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Berndt H. 2013-12-02 04:16:31 UTC
Description of Problem:


Steps to reproduce the problem:
1. Updated today on PC (asked me to download v1.8)
2. Installed, bound to Mac
3. Opened existing app
4. Added a new portable library
5. At some time I was asked to update the SDK
6. Did that (VS 2013 was closed without asking me)
7. Now my Xamarin add in does not load anymore
8. Copied complete project to MAC
9. Tried to open in Xamarin Studio
10. Portable library load failed - Unknown ToolsVersion '12.0'


Actual Results:
No development possible anymore

Expected Results:


How often does this happen? 
First time

Additional Information:
Comment 1 Mohit Kheterpal 2013-12-10 12:07:50 UTC
Today I have tried to reproduce this issue via following steps :

1. Create new iOS Project "abc" in VS 2013
2. Add a PCL project in it
3. Sync SDK (VS close)
4. Open VS and open same sample(abc)

Observed that project loaded successfully with PCL project. And I can also able to open it in XS on mac.

We are not able to reproduce this issue. 
Could you please provide us some sample? So that we can reproduce this issue. 

Note : Please correct me if I am doing something wrong to reproduce this issue.
Comment 2 Kirill Osenkov 2017-05-10 23:33:24 UTC
The PCL projects are now obsolete and superceded by .NET standard. We're resolving this bug, but please let us know if you experience any issues with projects in the latest Xamarin Studio.