Bug 16479 - Inherited WebService proxies fail on Invoke
Summary: Inherited WebService proxies fail on Invoke
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web.Services ()
Version: 3.2.x
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-11-27 10:34 UTC by Matt Welch
Modified: 2013-11-27 10:35 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 16479 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Matt Welch 2013-11-27 10:34:56 UTC
https://bugzilla.novell.com/show_bug.cgi?id=693367  <-- This old bug still exists.

I ran into it while attempting to integrate the eBay C# SDK into my Mono application. As a workaround, I built the eBay SDK from sources, adding the WebServiceBindingAttribute from eBay.Service.Core.Sdk.eBayAPIInterfaceService to the inherited eBay.Service.Core.Sdk.eBayAPIInterfaceService2.

That worked, but I believe the code change in the above Novell Bugzilla report will address the problem.
Comment 1 Matt Welch 2013-11-27 10:35:47 UTC
Documented my discovery of this in more detail here: http://stackoverflow.com/questions/20246362/ebay-c-sharp-sdk-doesnt-work-on-mono/20246363