Bug 16434 - Xamarin tools cause errors editing project properties in Visual Studio 2013
Summary: Xamarin tools cause errors editing project properties in Visual Studio 2013
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 1.8.x
Hardware: PC Windows
: High major
Target Milestone: 3.7
Assignee: vsx
: 16397 16451 16536 ()
Depends on:
Reported: 2013-11-25 04:52 UTC by Frank Buckley
Modified: 2014-07-31 06:28 UTC (History)
17 users (show)

Is this bug a regression?: ---
Last known good build:

Screenshot (50.90 KB, image/png)
2013-11-25 04:52 UTC, Frank Buckley
Screenshot 2 (19.43 KB, image/png)
2013-12-05 07:57 UTC, Frank Buckley
Screenshot 3 (56.80 KB, image/png)
2013-12-05 07:58 UTC, Frank Buckley
screenshot (117.60 KB, image/png)
2014-04-09 23:04 UTC, Anuj Bhatia

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Frank Buckley 2013-11-25 04:52:59 UTC
Created attachment 5527 [details]

Installing Xamarin Android and iOS tools in Visual Studio 2013 on Windows 8.1 results in errors when editing project properties in Android, iOS and other project types.

I have this happening on two Windows 8.1 installations, one of which was reinstalled having previously used Alpha releases of the Xamarin tools.

Latest stable versions for Android (4.10.1073) and iOS (1.8.365) are still exhibiting this behavior.

Steps to reproduce:

1. Install Xamarin tools for Windows using standard web installer.
2. Create a new Android Application project and build.
3. Edit project properties - e.g. change default namespace.
4. Save and close Visual Studio. (Note: at this point no error.)
5. Start Visual Studio and reopen project.
6. Now when attempting to change default namespace a "Catastrophic failure" results (screenshot).

Steps to show problem in non-Xamarin project types:

(With Xamarin tools installed)

1. Create new Windows Console Application.
2. Edit project properties - e.g. change default namespace.
3. Save and close Visual Studio. (Note: at this point no error.)
4. Start Visual Studio and reopen project.
5. Now when attempting to change default namespace a "System.Runtime.InteropServices.ExternalException" results.

Uninstalling Xamarin tools stops the error occurring.
Comment 1 Mohit Kheterpal 2013-11-26 12:54:27 UTC
Today we have check this issue with following builds :

All windows
VS 2013
X.Android 4.10.01073

We are able to reproduce this issue. And we are not getting any trace.0.logs for this.

Screencast : http://screencast.com/t/WIpLpshZ
Comment 2 Mohit Kheterpal 2013-12-02 05:54:45 UTC
*** Bug 16536 has been marked as a duplicate of this bug. ***
Comment 3 Frank Buckley 2013-12-04 14:43:57 UTC
I think Bug 16397 is likely the same as here - the exceptions reported vary with VS project type.

Together with other issues (e.g. Bug 16326 and broken XAML rendering in Windows Store apps), this problem effectively renders current builds of Xamarin Visual Studio tools unusable.
Comment 4 Frank Buckley 2013-12-04 18:20:54 UTC
As noted in the forums, I can confirm that faulting Android and iOS projects have <Project ToolsVersion="4.0"...
Comment 5 dean.ellis 2013-12-05 03:53:18 UTC
*** Bug 16397 has been marked as a duplicate of this bug. ***
Comment 6 dean.ellis 2013-12-05 03:55:04 UTC

Thank you for the solid steps to reproduce the error, we've been trying to track this down for a while.
Comment 7 Frank Buckley 2013-12-05 07:47:25 UTC
Although faulting Android and iOS projects appear to have <Project ToolsVersion="4.0"..., I have reinstalled latest stable bits and reproduced ExternalException editing properties of console application project (as above) and csproj has <Project ToolsVersion="12.0"...
Comment 8 Frank Buckley 2013-12-05 07:57:26 UTC
Also, with latest stable bits installed, spurious errors occur with design-time rendering of XAML in Windows Store applications (though apparently not WPF applications).

My steps to reproduce –

1. Install Xamarin tools for Visual Studio.
2. Open a solution in VS2013 with Windows Store applications and class libraries, Windows class libraries and WPF applications (but no Xamarin iOS/Android project types).
3. Wait a short while and then open a Windows Store application XAML file. Various errors will be reported (see additional screenshots).
4. Uninstall Xamarin tools. The errors go away.
Comment 9 Frank Buckley 2013-12-05 07:57:56 UTC
Created attachment 5608 [details]
Screenshot 2
Comment 10 Frank Buckley 2013-12-05 07:58:33 UTC
Created attachment 5609 [details]
Screenshot 3
Comment 11 Miha Markic 2013-12-06 02:58:25 UTC
Happens here as well - trying to change Target Android version and booom
Microsoft Visual Studio
Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))

VS2013,default Android project.
Comment 12 Miha Markic 2013-12-06 07:03:24 UTC
I think that's the same bug as described here
and duplicated here

At least the solution is the same in my case (delete .suo before opening solution).
Comment 13 Frank Buckley 2013-12-06 08:23:47 UTC
Yes for me too - deleting the .suo file prior to reopening solution prevents the errors previously described when editing properties of console project and when editing XAML in Windows Store applications.
Comment 15 Mohit Kheterpal 2013-12-12 10:49:39 UTC
Today we have checked this issue with following builds :

VS 2013
X.Android 4.10.02010
MTVS 1.10.30

Now we are not getting this issue. We are able to modify project properties in VS 2013.

Screencast : http://screencast.com/t/deavXhPebg

Hence closing this issue.
Comment 17 Saurabh 2014-02-27 12:54:26 UTC
Hi Dean,

I have tried to reproduce this issue at my end. I have tried it with xamarin android and console application By changing project's properties and closes VS and reopen the project same projects and modified their properties.

But I am not getting any error with xamarin and non-xamarin projects.

Screencast: http://screencast.com/t/de9gcaKLY

Windows 8.1
VS 2012/13
X.Android 4.12.0-28
Comment 18 Anuj Bhatia 2014-04-09 23:04:22 UTC
Is this a duplicate of this bug?


Reproduced as of 4-8-2014
Comment 19 Anuj Bhatia 2014-04-09 23:04:58 UTC
Created attachment 6546 [details]
Comment 20 Jose Miguel Torres 2014-07-31 04:10:19 UTC
Tested on XVS 3.3.46 and everything is now working correctly. No more error messagebox is displayed.
Comment 21 Jose Miguel Torres 2014-07-31 05:54:50 UTC
*** Bug 16451 has been marked as a duplicate of this bug. ***
Comment 22 Mohit Kheterpal 2014-07-31 06:11:11 UTC
I have checked this issue with XVS 3.3.46 and this issue does not exist as shown in screencast :http://screencast.com/t/ShgHMw2st0X

Hence closing this issue.

Environment info :
Microsoft Visual Studio Professional 2012
Version 11.0.61030.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Installed Version: Professional

LightSwitch for Visual Studio 2012   04938-004-0033001-02837
Microsoft LightSwitch for Visual Studio 2012

Office Developer Tools   04938-004-0033001-02837
Microsoft Office Developer Tools

Team Explorer for Visual Studio 2012   04938-004-0033001-02837
Microsoft Team Explorer for Visual Studio 2012

Visual Basic 2012   04938-004-0033001-02837
Microsoft Visual Basic 2012

Visual C# 2012   04938-004-0033001-02837
Microsoft Visual C# 2012

Visual C++ 2012   04938-004-0033001-02837
Microsoft Visual C++ 2012

Visual F# 2012   04938-004-0033001-02837
Microsoft Visual F# 2012

Visual Studio 2012 Code Analysis Spell Checker   04938-004-0033001-02837
Microsoft® Visual Studio® 2012 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Visual Studio 2012 SharePoint Developer Tools   04938-004-0033001-02837
Microsoft Visual Studio 2012 SharePoint Developer Tools

ASP.NET and Web Tools   2012.3.41009
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Windows Azure Web Sites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Windows Azure

NuGet Package Manager   2.8.50313.31
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.0
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   11.1.20627.00
Microsoft SQL Server Data Tools

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin (6029dc7c3575b82aca148081256b768c09a6c06e)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android
Comment 23 Mohit Kheterpal 2014-07-31 06:28:14 UTC
An update to the above comment, I have checked it on VS 2012/2013.

Here is the screencast of VS 2013 : http://screencast.com/t/4DiHDUDNtUla

And its working fine.