Bug 16397 - Changing the compile version in the dialog breaks VS
Summary: Changing the compile version in the dialog breaks VS
Status: RESOLVED DUPLICATE of bug 16434
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 0.x Insider Preview
Hardware: PC Mac OS
: Highest blocker
Target Milestone: ---
Assignee: Daniel Cazzulino
Depends on:
Reported: 2013-11-21 21:38 UTC by James Clancey
Modified: 2013-12-05 03:53 UTC (History)
8 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description James Clancey 2013-11-21 21:38:12 UTC
If you open an android project and go to the project settings. (works with creating a new project as well)
You then try and change the Compile using Android version dropdown and you get an error. 
The addin cannot recover from this. You have to force quit VS to fix it.

This is reproducible in the the latest alpha or stable


If you try and change the Target Android version you get a similar error. Those three drop-downs just don't work like they should.

Microsoft Visual Studio Professional 2013
Version 12.0.21005.1 REL
Microsoft .NET Framework
Version 4.5.51641

Xamarin.Android   4.10.01073 (d23a19bf)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   1.8.365 (8cb9dbd0)
Visual Studio extension to enable development for Xamarin.iOS
Comment 2 Mattia 2013-11-26 05:02:12 UTC
I have exactly the same problem.
Comment 3 dean.ellis 2013-11-29 05:33:46 UTC
Here are some details of the error

Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))

   at VSLangProj80.ProjectProperties3.set_RootNamespace(String pbstrRootNamespace)
   at Mono.Android.VisualStudio.ApplicationPage.ApplyChanges() in c:\Users\Dean\Documents\Projects\Xamarin\XamarinVS\Mono.Android.VisualStudio\PropertyPages\ApplicationPage.cs:line 188
   at Mono.VisualStudio.Extension.TastyPropertyPage.Apply() in c:\Users\Dean\Documents\Projects\Xamarin\XamarinVS\Mono.VisualStudio.Extension\FlavorProject\TastyPropertyPage.cs:line 228
   at Microsoft.VisualStudio.Editors.ApplicationDesigner.PropertyPageSite.ApplyStatusChange(UInt32 dwFlags)
Comment 4 dean.ellis 2013-11-29 06:06:30 UTC
I tried downloading the debug symbols and disabling Just My Code to see if we could get a better stack trace and now the bug is not happening.
Comment 5 Frank Buckley 2013-12-04 14:40:24 UTC
I see the same error - together with other exceptions in other project types in VS2013 - seems likely related to Bug 16434. I also see issues similar to those reported in Bug 16326.
Comment 6 dean.ellis 2013-12-05 03:53:18 UTC

*** This bug has been marked as a duplicate of bug 16434 ***