Bug 16378 - I am getting 'New Image Set', 'New App Icon' and 'New Launch Image' sub-options under References->Add option
Summary: I am getting 'New Image Set', 'New App Icon' and 'New Launch Image' sub-opti...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 4.2.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-11-21 03:45 UTC by narayanp
Modified: 2013-12-17 05:41 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2013-11-21 03:45:35 UTC
Steps to reproduce:
1. Open XS.
2. Create or open any application.
3. Right click on References->Add.

Actual result: User seeing  'New Image Set', 'New App Icon' and 'New Launch Image' sub-options. While they are only applicable when user right clicks on .xcassets folder in solution explorer for iOS application.

Expected Result: 'Add' option should not be displayed after right clicking on References.

Supplement info:
http://screencast.com/t/Zup1yxxIXJ


Environment details:
All Mac
X.S 4.2.2(build 2)
Mono 3.2.4
X.iOS 7.0.4.211
X.Android 4.10.1-68
Comment 1 Jeffrey Stedfast 2013-11-21 15:02:53 UTC
fixed in git master
Comment 2 Akhilesh kumar 2013-12-17 05:41:45 UTC
Today we have checked this issue with following builds :

XS 4.2.3 (build 20)
X.iOS 7.0.6.164

Now 'Add' option is not displaying after right clicking on References.

Screencast : http://screencast.com/t/quM09nECsnB

Hence closing this issue.