Bug 16340 - Intellisense stops working
Summary: Intellisense stops working
Status: VERIFIED DUPLICATE of bug 16843
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 4.2.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-11-19 09:49 UTC by Dylan
Modified: 2014-03-12 03:35 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log file for broken intellisense (431.89 KB, application/octet-stream)
2013-12-09 07:32 UTC, Dylan
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 16843

Description Dylan 2013-11-19 09:49:13 UTC
Noticed this after the 4.2.x upgrade. After a while, intellisense in the designer completely stops working. No errors given and no hint of any suggestions. Source Analysis was turned on and even this has stopped working. Only way to fix is to restart Xamarin Studio.
Comment 1 Dylan 2013-11-19 09:51:05 UTC
Not designer, meant in open files.
Comment 2 Mikayla Hutchinson [MSFT] 2013-11-19 14:30:00 UTC
I assume you mean C# files?

Please attach logs (Help -> Open Log Directory).
Comment 3 Mike Krüger 2013-11-20 02:46:15 UTC
Strange never happened for me - I think there is an exception somewhere in the logs -> we need that.
Comment 4 Dylan 2013-11-20 02:47:15 UTC
Yeah in C# files. I'll grab you some logz next time this happens. Happens on more than three of my developer's machines.
Comment 5 Dylan 2013-12-09 07:32:18 UTC
Created attachment 5622 [details]
Log file for broken intellisense

Intellisense broken more than once today. Have to restart to fix.
Comment 7 Mike Krüger 2014-01-02 05:38:23 UTC
Thanks for the log - fixed
Comment 8 Mike Krüger 2014-01-02 05:38:55 UTC

*** This bug has been marked as a duplicate of bug 16843 ***
Comment 9 Sadik Ali 2014-03-12 03:35:30 UTC
I have verified this issue on below environments:

All Mac
Xs 4.2.4 (build 30)
Build Information
Git revision: dca4b8cd2756833329f16b7e513f325286846d4e
Xamarin addins: a70271467d292010ed315f9f1924db1ecde542d1

As this issue is duplicate of bug 16843 so I checked this issue with following code:

public static readonly Dictionary<byte, string> Keywords = new Dictionary<byte,
string>{ } 

I typed '{' and noticed that no exception is generated

Refer screen cast: http://screencast.com/t/GZbLuMoUdIW

hence I marked this as verified.