Bug 16243 - XS 4.2 and Xamarin.iOS 7.0.4 // Portable Class Library no longer compatible
Summary: XS 4.2 and Xamarin.iOS 7.0.4 // Portable Class Library no longer compatible
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 7.0.4.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: 7.0.6
Assignee: Martin Baulig
Depends on:
Reported: 2013-11-14 16:19 UTC by Jacco Rademaker
Modified: 2013-12-13 09:40 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Screenshot, version info, sample project (279.51 KB, application/zip)
2013-11-14 16:19 UTC, Jacco Rademaker

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jacco Rademaker 2013-11-14 16:19:42 UTC
Created attachment 5435 [details]
Screenshot, version info, sample project

I just updated my Xamarin development environment and now I’m no longer able to build my iOS-application.
The application has several Portable Class Libraries (using profile 49) and this was working fine previously.
In the new version, I get a warning that these PCL projects are not compatible.

In the attachment you'll find:
- a screenshot illustrating the problem
- my Xamarin version info
- a sample project

I hope you’re able to help me to get my solution working (again).
Comment 1 Mikayla Hutchinson [MSFT] 2013-11-14 18:29:22 UTC
What's the contents of your /Library/Frameworks/Mono.framework/Versions/Current/updateinfo file?
Comment 2 Jacco Rademaker 2013-11-15 02:16:45 UTC
Current/updateinfo -> 964ebddd-1ffe-47e7-8128-5ce17ffffb05 302040000
Comment 3 Jacco Rademaker 2013-11-15 02:27:51 UTC
Just got an email from support@xamarin (Prashant Cholachagudd).
He pointed me at /Library/Frameworks/Mono.framework/Versions/3.2.4/lib/xbuild-frameworks/.NetPortable and asked if it was empty.
Well, the .NetPortable folder isn't there at all.

I will reinstall the Mono framework as suggested by him and post the result.
Comment 4 Jacco Rademaker 2013-11-15 03:10:47 UTC
I did reinstall the framework, but still did not see the .NetPortable folder.
Then found out I was caught by the OSX default behavior of not showing folders with a dot… 
Now the folder is visible and contains the expected contents (I think).

In addition, when editing the references on the iOS project, I'm not able to select the PCL-project with profile 49. (Probably because XS thinks it's not compatible.)

Problem not solved yet.
Comment 5 Jacco Rademaker 2013-11-15 04:12:20 UTC
Next I have completely removed the Mono.framework folder and reinstalled the framework.

I’m now able to build my entire solution, problem solved.

(This may all have been caused by some manual modifications earlier this year to get PCL’s working with MVVMCross.)
Comment 6 PJ 2013-12-11 18:46:00 UTC
This fix is planned to be released with Xamarin.iOS 7.0.6, which should hit the beta channel before December 23rd.
Comment 7 Mohit Kheterpal 2013-12-13 09:40:51 UTC
As per comment 5, this issue does not exist any more.

Hence closing this issue.