Bug 16187 - Opening 'properties' hangs the project
Summary: Opening 'properties' hangs the project
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: vsx
Depends on:
Reported: 2013-11-13 07:43 UTC by Andy
Modified: 2016-09-15 17:25 UTC (History)
11 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andy 2013-11-13 07:43:54 UTC
Connection to Mac is fine
Comment 1 Alan McGovern 2013-11-14 14:16:57 UTC
Jose, can we review the code to see why this is happening? We should not be doing anything blocking the UI when opening this file.
Comment 2 Andy 2013-11-27 06:55:03 UTC
by the way, it keeps happening. Can't edit properties anymore
Comment 3 Andy 2013-11-27 06:56:05 UTC
And, I forgot: all my icons for project properties have been lost !
Comment 4 Andy 2013-11-27 07:06:30 UTC
In fact, all my project properties got erased ! Great !!!
Comment 5 Andy 2013-11-27 07:15:55 UTC
This would be funny if one had enough time to report all the glitches. 

I decided that I am the bug, because I keep trying to use VS.iOS while it's just a loss of time. So I moved back to the Mac and Xamarin Studio, where I re-added all properties, manually, all icons, etc. It took a _very_ long time to find the correct icons I chose in the past, also because the open file dialog is glitchy at best...

Then as soon as I checked 'Prerendered', the program asked for my admin password (Debugger tools need it ?). Then the whole Xamarin Studio hangs and I had to force quit it. 

Yes, you guessed it, all properties lost again.
Comment 7 Vinicius Jarina 2013-11-27 12:53:11 UTC
Hi Andy

Sorry about this experience.

Could you give some instruction how to repro your issue?

I tried the 'properties' page here in 3 different scenarios: without network, connected to the Mac, with network but disconnected from Mac. 


I was not able to repro.

Thank you very much.

Vinicius Jarina.
Comment 8 Andy 2013-11-29 13:31:43 UTC
It doesn't happen on all projects. One in particular seems screwed up, it has all warning icons on the files and locks the properties page, also resetting it !!!!
Comment 9 Andy 2013-12-02 13:59:52 UTC
Again here like the other 16473 bug, I think your editor screwed something on VS only on some projects...
Comment 10 Andy 2014-01-05 15:26:07 UTC
Should I keep my project on the MAc or PC ?
Comment 11 Marek Habersack 2014-01-07 08:23:30 UTC
On PC is the most effective location.
Comment 12 Jose Miguel Torres 2014-07-31 04:32:11 UTC
Hi Andy, could you check if this issue is still happening with the very latest released version? 

Comment 13 Andy 2014-07-31 04:37:14 UTC

last time I tried this, I think it corrupted my project, so I am afraid I can't risk it now.

Besides, I had to uninstall VS 2010 since VS.iOS plugin intercepted keystrokes again (there's a bug somewhere) and I couldn't work
Comment 14 Akhilesh kumar 2015-08-05 11:47:22 UTC
As this issue does not exist with all project and we are unable to reproduce this issue at our end.

So I am closing this issue.

Feel free to reopen it or file a new bug with logs, if anyone still facing this issue.