Bug 16182 - SDK keeps updating
Summary: SDK keeps updating
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Windows
: High critical
Target Milestone: 1.12 (Merge)
Assignee: Jose Miguel Torres
Depends on: 16211
  Show dependency tree
Reported: 2013-11-13 06:43 UTC by Andy
Modified: 2013-12-17 05:45 UTC (History)
10 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andy 2013-11-13 06:43:39 UTC
It's not fixed. It keeps updating the SDK at every restart
Comment 1 Jose Miguel Torres 2013-11-13 12:34:26 UTC
Hello Andy,

Does the SDK crash? I mean, are you able to see the progress bar indicating the SDK is being downloaded?
Comment 2 Andy 2013-11-13 12:35:49 UTC
If fills up, then disappears and nothing else

it happened three times. It also tried to update the docs, failed halfway and never asked again.
Comment 3 Jose Miguel Torres 2013-11-13 12:38:39 UTC
Could you send me the file %LOCALAPPDATA%\Xamarin\Logs\SDKUpdate.log please?
Comment 4 Jose Miguel Torres 2013-11-13 12:43:31 UTC
On the other hand, I need more info. Please follow these steps:

- Look at %TEMP% you will find a bunch of numeric folders something like (%TEMP%\635199590928050048).
- Open the more recent one an open the zip you will find inside.
- Let me know how many files are listed there and if possible their names.

Let me know which Xamarin.iOS version are you using on Mac and VS please...

thanks Andy,
Comment 5 Alan McGovern 2013-11-13 19:04:38 UTC
A potential fix for this is described in bug #16211. That fix may not completely fix this problem so it will have to be checked thoroughly.
Comment 6 Andy 2013-11-15 05:03:24 UTC

no such dir. I have 

there's a 
Comment 7 Andy 2013-11-15 05:09:45 UTC
I got the message again today. 

It's updated successfully, it seems
Comment 8 Jose Miguel Torres 2013-11-15 12:06:55 UTC
Hello Andy,

If you saw the monotouch.xml file it means that the documentation has been updated and as a consequence the monotouch.xml has changed. Hence the SDK sync has been launched in order to bring the new monotouch.xml to VS. 

This process is going to be entirely redesigned for future release, right now it's been a expected behavior.

I am about to close this bug. Please feel free to reopen it if you notice unexpected behavior.

Thanks for your collaboration.
Comment 9 narayanp 2013-11-29 08:49:51 UTC
Today I have checked this issue with following builds:

Windows 8.1
VS 2013/2012
MTVS 1.10.12

After completing SDk documentation merging(When Installation completed using iOS.VisualStudio.Documentation.Manager), I am getting 'msbuild' and 'Mono.IO.VisualStudio.Documentation' under C:\Users\Administrator\AppData\Local\Xamarin\Log\MonoTouchVS. These are the gist for the same:


But I am not seeing monotouch.xml. Please suggest me for the same.
Comment 10 Andy 2013-12-05 11:33:02 UTC
Still seems dodgy. I updated XS today, then only after many hours VS fired an SDK warning....
Comment 11 Andy 2013-12-05 11:34:57 UTC
Correction. It just fired again, right away, after reopening VS and a iOS project.

So definitely not fixed.

Also, if I choose not to update at the modal messagebox (which prevents changing stuff in VS), how can I get the same prompt ?
Comment 12 Andy 2013-12-06 08:27:50 UTC
And it keeps happening roughly every day
Comment 13 Andy 2013-12-14 06:39:43 UTC
Could it be due to me using old SDK 6 along with SDK 7 ?
Comment 14 Jose Miguel Torres 2013-12-17 04:12:47 UTC
Hi Andy, it's unlikely but possible. Did you find out the reason?
Comment 15 Andy 2013-12-17 05:09:27 UTC
Not at the moment. I switched to 7 and got the popup at least once. But probably less than before. 

Can I suggest performing this stuff silently in the future when you fixed it ? I don't see much value in answering "no" to the popup
Comment 16 Jose Miguel Torres 2013-12-17 05:45:15 UTC
Sure. This stuff will be redesigned and I will take your feedback into account. Hence, changing the status to Feature.