Bug 16117 - [iOS]iOS Debugger fails to connect and Apps fails to launch on iPhone 5 (7.0.3) device
Summary: [iOS]iOS Debugger fails to connect and Apps fails to launch on iPhone 5 (7.0....
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 7.0.4.x
Hardware: PC Mac OS
: --- normal
Target Milestone: 7.0.4 (Activation)
Assignee: Bugzilla
Depends on:
Reported: 2013-11-11 15:08 UTC by GouriKumari
Modified: 2013-11-11 16:37 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Comment 1 GouriKumari 2013-11-11 15:31:39 UTC
I restored the device again with iOS 7.0.3 and the error that I reported initially no longer occured. I could sucessfully launch and deploy monotouch-test on device. 

Also, on launching iOS projects from Xamarin Studio, debugger got successfully connected and application got launched successfully. 

Test Env:
Test Env:
Xamarin Studio
Version 4.1.13 (build 17)
Installation UUID: 6b08c64b-dbf4-4817-b167-d94ad0b26ad5
    Mono 3.2.4 ((no/294f999)
    GTK+ 2.24.20 theme: Raleigh
    GTK# (
    Package version: 302040000

Apple Developer Tools
Xcode 5.0 (3332.25)
Build 5A1413

Version: (Trial Edition)
Hash: 7c20725
Build date: 2013-11-11 09:32:22-0500

Device Info:
iPhone 5, 7.0.3(11B511)
Comment 2 Sebastien Pouliot 2013-11-11 16:32:25 UTC
It's likely just a reboot (not a restore) would have worked. That should be tried first when an issue seems to be device-specific.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2013-11-11 16:37:53 UTC
The crash report is for a different process, not monotouch-test. There is no mention of 'monotouh' in the device log either, so I believe this to be a fluke in Apple's code.

Closing for now, if it happens again we can always reopen.