Bug 16039 - System.IO.FileNotFoundException: Could not load assembly 'Cirrious.CrossCore, Version=, Culture=neutral, PublicKeyToken=null'. Perhaps it doesn't exist in the Mono
Summary: System.IO.FileNotFoundException: Could not load assembly 'Cirrious.CrossCore,...
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 4.10.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
: 19986 ()
Depends on:
Reported: 2013-11-08 08:06 UTC by g-gangster1994
Modified: 2017-08-23 21:29 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Project with the .Droid error in VS (904.35 KB, application/octet-stream)
2013-11-26 08:46 UTC, g-gangster1994

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description g-gangster1994 2013-11-08 08:06:34 UTC
Always when I wanna build my Android app, this error occures: System.IO.FileNotFoundException: Could not load assembly 'Cirrious.CrossCore, Version=, Culture=neutral, PublicKeyToken=null'. Perhaps it doesn't exist in the Mono for Android profile?	

Cirrious.CrossCore exists definetly.
I tried to replace <AndroidApplication>true</AndroidApplication> in Droid.csproj and than building, but same error occures. 

my References in there are like this:

  <Reference Include="Cirrious.CrossCore">


Xamarin Version: 4.0.13
Comment 1 g-gangster1994 2013-11-20 10:00:26 UTC
Updated Xamarin + NuGet, still same error
Comment 2 g-gangster1994 2013-11-20 10:01:05 UTC
This error occures in all Projects
Comment 3 dean.ellis 2013-11-20 10:16:50 UTC
Are you using the beta versions of MVVMCross? The maintainer of that library recently released a video explaining how to get his library to work with the latest Xamarin PCL support. You will probably need to change your PCL profile to get this working.



This is the video explaining how to migrate to the new profiles.
Comment 4 g-gangster1994 2013-11-20 10:19:30 UTC
I tried this today, too. on 8:10 when i build my Droid project, the error occures
Comment 5 g-gangster1994 2013-11-20 10:21:18 UTC
I made exactly the same like in this video, but with older versions of Xamarin, the error occured, too. In the last weeks i made N=1 till 4 and in every .Droid project it occures...
Comment 6 dean.ellis 2013-11-20 10:23:48 UTC
make sure you are running the latest Nuget package manager in you IDE. There are fixes for PCL support in the latest version of Nuget. 
What IDE are you using btw? VS2010/12 or 13. 

you need to be running on 4.10.1 of Xamarin.Android for PCL to work correctly.
Comment 7 g-gangster1994 2013-11-20 10:29:36 UTC
VS 12 Premium - NuGet i updated before i builed the Project from the video.
4.10.1 (Trial Edition)
Comment 8 dean.ellis 2013-11-20 11:11:19 UTC
Are you just opening the project or running through the tutorial yourself? If you are just opening the project you need to enabled the setting in the Package Manager to allow nugget to download missing packages (Tools->Library Package Manager->Package Manager Settings)

I'm not sure you are using the 'beta' packages as per the video. In Nuget when you search online for the packages you need to switch the combo box in the top left from Stable to Prerelease. 

I did this and the version of MvvmCross I have is 3.0.14 and I have the correct files in 

Comment 9 g-gangster1994 2013-11-20 11:21:17 UTC
I updated the NuGet, than i coded the project, than i build the project, and i chose Include Prerelease like in the video.
Tomorrow i will reinstall xamarin, maybe it will help, you will hear from me :) and thx
Comment 10 g-gangster1994 2013-11-21 02:36:34 UTC
Ok, i reinstalled Xamarin.Android (4.10.01073), but if i wanna build any Droid Project, the error occures... :/
Comment 11 g-gangster1994 2013-11-21 03:14:38 UTC
if i remove reference "Cirrious.CrossCore", the same error occures with "Cirrious.CrossCore.Droid", if i remove this reference, the same error occures with other assemblys... till Demo.Core, if i delete this reference, several errors occure
Comment 12 g-gangster1994 2013-11-21 07:05:22 UTC
*NuGet is allowed to load missing packages, since i got VS :)
Comment 13 g-gangster1994 2013-11-25 08:37:24 UTC
I used the project in Xamarin Studio, removed the references and get them new, than on xamarin studio it ran. But why it don't going on in VS 2012 :/
Comment 14 dean.ellis 2013-11-26 04:52:32 UTC
Can you attach a complete zipped up version of your project (including binaries and packages) . We will try to replicate the issue here.
Comment 15 g-gangster1994 2013-11-26 08:44:00 UTC
ok i will do, and the error comes there:

		<Output TaskParameter="ResolvedResourceDirectories" PropertyName="LibraryResourceDirectories" />
		<Output TaskParameter="ResolvedAssetDirectories" PropertyName="LibraryAssetDirectories" />
		<Output TaskParameter="ResolvedEnvironmentFiles" PropertyName="LibraryEnvironments" />

#### Xamarin.Android.Common.targets -> line 628
Comment 16 g-gangster1994 2013-11-26 08:46:39 UTC
Created attachment 5546 [details]
Project with the .Droid error in VS
Comment 17 g-gangster1994 2013-11-29 08:34:26 UTC
Some results till now? :)
Comment 18 g-gangster1994 2013-12-13 07:27:35 UTC
Or you even was able to reproduce the Issue?
Comment 19 Johan Högfeldt 2014-05-30 04:50:58 UTC
*** Bug 19986 has been marked as a duplicate of this bug. ***
Comment 20 Johan Högfeldt 2014-05-30 04:51:26 UTC
I have solved the issue, which is a general issue: It turns out that it is due to restrictions in directory name length. Directories can not exceed 256 characters, and for me having a long name it turned out the components directory names got to long. The solution was moving the project directory from my user directory to C:.
Comment 21 Nuno Henrique 2015-05-15 05:59:11 UTC
guys any news here? it's still occurring
Comment 22 Cody Beyer (MSFT) 2017-08-23 21:29:52 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.