Bug 15955 - Solution never finishes loading when build host not available
Summary: Solution never finishes loading when build host not available
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Windows
: High major
Target Milestone: 1.12 (Merge)
Assignee: Alan McGovern
Depends on:
Reported: 2013-11-06 06:08 UTC by Øystein Krog
Modified: 2014-02-14 06:08 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

Trace log (14.76 KB, application/octet-stream)
2013-11-12 09:47 UTC, Øystein Krog

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Øystein Krog 2013-11-06 06:08:02 UTC
If the OS X build host is not accessible by the Xamarin.iOS extension the project solution never finishes loading.
In solution explorer it says: Solution 'X' (loading...).

The cause can be many things, I've seen it happen if I forget to start the OS X vm I'm using, or if the OS X vm is using a different version than the extension.

This breaks several things, e.g. ReSharper never starts solution analysis (stuck in Initializing).
In earlier versions of the VS extension I've also seen projects stuck in the loading state, but I am not seeing this with v1.8 alpha any more.
Comment 1 Alan McGovern 2013-11-06 09:09:16 UTC
Can you provide a screencast of the issue and/or the log file found in this directory:


We only store the log for the last time you ran Visual Studio, so you will have to run VS and hit the bug and then give us the log file. This information should help us diagnose the issue.

Can you also confirm which version of VS you are running?
Comment 2 Øystein Krog 2013-11-06 10:07:13 UTC
I just tried to reproduce this but failed, I'll keep a lookout and see if I can trigger it again.
Maybe there is something else that causes the problem, I'm not sure.
I'm using VS2013 (and Xamarin.iOS 1.8.269).
Comment 3 Alan McGovern 2013-11-06 10:42:35 UTC
One of our developers has reported the same issue but we cannot narrow down a cause yet. Thanks for the additional information. We'll update the bug report again when we have more information. If you do manage to trigger it again it would be great to get the log.

Comment 4 Marek Habersack 2013-11-06 18:13:00 UTC
I've just tried it with both master and the current 1.8 branch (not yet released) code and it does not happen anymore.

Øystein, I'm going to mark it as fixed - please re-test it once next 1.8 alpha (or beta) is released and reopen if it still occurs for you.
Comment 5 Mohit Kheterpal 2013-11-08 07:26:02 UTC
Today we have checked this issue with following builds :

VS 2013
MTVS 1.8.314

Now we are able to create project when mac build host is not available. And we are not getting any issue with loading project.

Screencast : http://screencast.com/t/BToadGrX21

Hence closing this issue.
Comment 6 Øystein Krog 2013-11-12 09:46:25 UTC
I tested this with the latest alpha again today and it's still happening for me.

VS 2013.
I installed MTVS 1.8.314 and connected with a OS X system with the very latest alpha channel release, then I did an SDK/doc sync .
It is worth noting that even though I keep clicking the SDK sync popup it fails and then reappears later, when I initially made this issue I did not have this problem (seems to have appeared with the latest ios channel alpha).

I've found one repro-case today:
1. Open an instance of VS2013 and open a solution with iOS projects in it, this instance does not have any problems.
2. Open a second instance and open a different solution with iOS projects in it, this instance will have the problem and even if you close the first instance and reload the solution the problem remains.

The way MVTS does the build host is very problematic when you have a workflow that demands use of multiple VS instances.

I have seen this problem appear even when just switching between solutions with a single VS instance, but that seems to be harder to reproduce.

Some actions will resolve the loading problem; clean solution, start debug etc.

I've added a trace log.

Here is a screen cast: 
Comment 7 Øystein Krog 2013-11-12 09:47:14 UTC
Created attachment 5398 [details]
Trace log
Comment 8 Alan McGovern 2013-11-12 12:33:19 UTC
Perfect! That repro case sounds like we were investigating the wrong thing previously. I will look into this immediately.
Comment 9 Dominique Louis 2014-01-21 06:47:09 UTC
Alan you mentioned you were looking at this. Any updates?
Comment 10 Marek Habersack 2014-01-22 09:13:03 UTC
Alan, can you update us on the progress here?
Comment 11 dean.ellis 2014-01-29 11:39:20 UTC
I cannot replicate this issue with 2 or more instances of Visual Studio each having an iOS project. 
Can I ask if you can update to the 1.10 release of MTVS (in beta) if you have not already done so. There were some fixes to VS2013 that might effect its behaviour.
Comment 12 Dominique Louis 2014-02-13 15:20:51 UTC
I've also tested this today and am not able to reproduce using master or 1.12.

Alan if you are still seeing this, please re-open.