Bug 15879 - Projects using support library crashing on Android V2.3 but working on V4+
Summary: Projects using support library crashing on Android V2.3 but working on V4+
Status: RESOLVED DUPLICATE of bug 15542
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 4.10.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2013-11-01 13:10 UTC by michele.scandura
Modified: 2013-11-01 13:37 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Log from LogCat (17.97 KB, text/plain)
2013-11-01 13:10 UTC, michele.scandura

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description michele.scandura 2013-11-01 13:10:19 UTC
Created attachment 5311 [details]
Log from LogCat

I created a project using Support libraries (v4 from the component store).
Project builds and runs ok on Android 4+.
On a Nexus One (Android 2.3) it crashes on startup.
I also tried with the SupportV4 sample from Xamarin samples on github, with the same result.
See attached logfile
Comment 1 michele.scandura 2013-11-01 13:18:59 UTC
stacktrace looks similar to this one https://bugzilla.xamarin.com/show_bug.cgi?id=15513
Comment 2 Jonathan Pryor 2013-11-01 13:37:30 UTC
If you're using the 4.10.0 alpha, this is Bug #15542.

*** This bug has been marked as a duplicate of bug 15542 ***