Bug 15822 - [iOS-VS] "Invalid pin entered error" prevents user from pairing with a build host
Summary: [iOS-VS] "Invalid pin entered error" prevents user from pairing with a build ...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.8.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Dominique Louis
Depends on:
Reported: 2013-10-30 11:52 UTC by GouriKumari
Modified: 2014-03-27 07:32 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description GouriKumari 2013-10-30 11:52:56 UTC
Steps to reproduce:

Install Xamarin.iOS for VS 1.8.214.msi

Create a new iOSproject to trigger connect build host dialog wizard. 
Select a macbuild host and add connect.
Pair VS with buildhost.

Actual Behaviour:

"The pin you entered was invalid. Please enter a valid pin" error is thrown.

Supplemental Info:
I tried to unpair to generate a new pin, however it threw the same error again.
Also, tried connecting to another macbuild host which also gave the same invalid pin error. 
Screencast: http://screencast.com/t/jlL5SMg1

Test Env:
Xamarin.ioS for VS 1.8.214.msi
MT /Lion
Comment 1 GouriKumari 2013-10-31 16:54:06 UTC
Retested again with Xamarin.iOS for VS 1.8.239.msi. I am now able to pair successfully with build host. "Invalid pin entered" error is no longer occuring.

Marking bug as resolved fixed.

ScreenCast: http://screencast.com/t/sjyrEO3eNPp

Test Env:
Xamarin.iOS for VS 1.8.239.msi.
Comment 2 narayanp 2014-03-27 07:32:43 UTC
I have checked this issue with following build:

Xamarin for VS 1.12.247
X.iOS 7.2.1-63

I am also successfully able to pair with build host. "Invalid pin entered" error does not appear.

Closing this issue now.