Bug 15679 - Connection error is preventing build even though the project isnt set to build
Summary: Connection error is preventing build even though the project isnt set to build
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.6.x
Hardware: PC Mac OS
: High blocker
Target Milestone: 1.8.x (VS2013)
Assignee: James Clancey
Depends on:
Reported: 2013-10-24 21:23 UTC by James Clancey
Modified: 2015-01-05 11:20 UTC (History)
11 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description James Clancey 2013-10-24 21:23:25 UTC
I have a solution that has an iOS project and a Windows Store project.

My current configuration has the iOS project disabled.

I have fiddler 2 opened which causes a connection issue for X.iOS

I click build, and i get an activation build error.

Since the iOS project is disabled in this configuration It should not be trying to communicating with the Mac build server.
On top of that it should never error and prevent me from building a project that does not depend on our iOS addin.
Comment 1 dean.ellis 2013-10-25 10:25:11 UTC

I'm having trouble replicating this. When I disable a iOS project in the configuration manager (by unchecking the build box) is skips the project, this is while I am not connected to the mac host and it doesn't try to connect.

Any chance you can screencast the issue for us?
Comment 2 James Clancey 2013-10-25 13:41:28 UTC
I can get you a screen cast, but its really easy to replicate.  Just download fiddler 2 ( http://fiddler2.com/get-fiddler ) and turn it on once you are already connected.

Joseph also had this happen when he installed and had not activated his products yet.  When it happened to him, he didnt even have any of our projects loaded in the solution.
Comment 3 dean.ellis 2013-10-28 12:18:10 UTC
I've installed Fiddler2 and started it. And it does stop server communications. 
That said I am still able to debug and run a WPF app even though I have a iOS app in the solution (and its not set to Build in the configuration manager). 

This is on VS2012. What version of VS are you testing on?
Comment 4 James Clancey 2013-10-28 12:24:08 UTC
VS 2013. Sorry should have said that sooner.
Comment 5 dean.ellis 2013-10-28 13:02:53 UTC
ok, I'll see if I can replicate it on vs2013. Will need to reset my surface and upgrade to 8.1 then install vs2013... fingers crossed it all goes well.
Comment 6 dean.ellis 2013-10-29 08:17:30 UTC

I tried this in VS2013 on my Surface Pro using the Xamarin.iOS build, I was still able to build and run the Windows Store app when fiddler was running as long as the iOS project did NOT have Build checked in the Configuration Manager. 

If it did have build checked then I got a build error (as i would expect), but I was still able to run and debug the Windows Store app.
Comment 8 PJ 2013-10-31 12:31:40 UTC
I tried to reproduce this today just to get it off the list and I don't think the issues remain.

I'm not sure of the exact reproduction steps but here's what I did:

I created an iOS project
I ensured it deployed successfully
I opened fiddler 2
The connection was lost (which is correct)
I added a WPF project to the solution
I set the WPF project to be the startup project
I unloaded the iOS project
I built

It built and launched just fine.
The project builds and launches just fine with and without Xamarin licenses now.

Test Environment:
MTVS 1.8.214

Not completely current builds, but later than the reported builds.
James, can you still reproduce this?
Comment 9 dean.ellis 2013-10-31 18:09:12 UTC

rather than unload the iOS project, you just need to uncheck the build checkbox in the Configuration Manager for your active configuration (if I understand the original bug report).

If the solution still builds ok, then its not an issue anymore

Comment 10 PJ 2013-11-01 13:43:52 UTC
So yeah, with the iOS project not being set to build/deploy, the build is not blocked on MTVS connection being blocked by either fiddler or unpairing the build host: http://screencast.com/t/J5tdGsW7Hd4k

I do see that the pairing error can linger in the error list, but it's not stopping the build, and it's not an activation error as originally reported: http://screencast.com/t/eWrwJa6R8j4c

I believe the issue as reported by James is fixed, and you will not be blocked from using the non-Xamarin parts of solutions while unpaired / running fiddler.


MTVS 1.8.258