Bug 15610 - svn broken with Mavericks
Summary: svn broken with Mavericks
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 4.1.12
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2013-10-23 06:54 UTC by Paul Johnson
Modified: 2014-02-04 11:07 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Paul Johnson 2013-10-23 06:54:49 UTC
I have the latest version of Xam.Studio (alpha) installed on my mac running OS X 9, the svn plugin is installed and svn is installed on my mac from macports (so it's reading as 1.7.10).

Prior to upgrading, the svn plugin was working fine. Post upgrade, the plugin is registered but when I try to commit to an svn repo or checkout from svn, the option to do this has vanished from Xam.Studio.

svn is running fine from the command line or using svnx
Comment 1 Mikayla Hutchinson [MSFT] 2013-10-23 15:59:28 UTC
Confirmed:
WARNING [2013-10-23 13:03:52Z]: Subversion addin could not load libsvn_client, so it will be disabled

However, there does seem to be a 32-bit libsvn_client on my system:

file /usr/lib/libsvn_client-1.0.0.0.dylib 
/usr/lib/libsvn_client-1.0.0.0.dylib: Mach-O universal binary with 2 architectures
/usr/lib/libsvn_client-1.0.0.0.dylib (for architecture i386):	Mach-O dynamically linked shared library i386
/usr/lib/libsvn_client-1.0.0.0.dylib (for architecture x86_64):	Mach-O 64-bit dynamically linked shared library x86_64
Comment 2 Marius Ungureanu 2013-10-30 09:07:25 UTC
Either macports installs libsvn with another name than the default Xcode one, it's wrong. Apparently, on my Mavericks machine, libsvn is missing.
Comment 3 Marius Ungureanu 2013-10-30 09:22:41 UTC
It is a macports issue. Xcode developer tools installs the correct dylib.
Comment 4 Timur Zanagar 2013-10-31 03:39:47 UTC
After updating to Mavericks I don't have SVN either in Xamarin Studio. Command line Svn works. Didn't ever have installed MacPorts.
Comment 5 Marius Ungureanu 2013-10-31 08:51:15 UTC
@Timur: Does running xcode-select --install then trying subversion in Xamarin Studio work?
Comment 6 Timur Zanagar 2013-10-31 09:12:50 UTC
@Marius: No! Installed - restarted - opened a solution which is definitely under SVN. As I wrote - command line svn works like a charm, but not in Xamarin Studio (alpha channel - 4.1.12 (build 6)) after upgrading to Mavericks anymore.
Comment 7 Calin Turcu 2013-11-01 07:11:54 UTC
can confirm the issue - I've reported it in the forums a few days ago. Svn is working from command line and a 3rd party tool.
Comment 8 Marius Ungureanu 2013-11-01 07:17:31 UTC
I'll take a look at it today and find a cause, not a symptom.
Comment 9 Timur Zanagar 2013-11-01 11:00:36 UTC
@Marius: Just clean installed my MBP 2010 with Mavericks, latest XCode, installed command line tools with xcode-select --install and Xamarin (in that order). SVN works via command line without any problems, but there is no SVN in the Drop Down List. Just GIT.
Comment 10 Paul Johnson 2013-11-01 21:58:36 UTC
worth mentioning that macport svn is now on 1.8 rather than 1.7 for Xcode
Comment 11 Marius Ungureanu 2013-11-02 05:52:15 UTC
Yeah, and I have found the issue.

The problem is that libsvn_client has no symlink in /usr/lib. The way command line works is probably by referencing the one in Xcode.app with xcrun. :(

Trying to find an elegant solution to this.
Comment 12 Marius Ungureanu 2013-11-02 06:07:36 UTC
As a completion to the above comments.

svn in command line works because svn binary is in /usr/bin.
Comment 13 Himanshu 2013-11-10 02:18:19 UTC
upgraded to Alpha latest version. still facing SVN issue.

Any update or release plan?
Comment 14 Costas Economopoulos 2013-11-11 08:24:08 UTC
I am facing the same.
Any update on the issue?
Comment 15 Alan McGovern 2013-11-11 14:18:14 UTC
The only thing that needs to be done is to install the Xcode Commandline Tools package. This install svn in the correct location.

To do this you need to launch Xcode and then click on Xcode -> Developer Tools -> More Developer Tools. Once you log into the apple developer site just install the corresponding Commandline Tools packaging for your OS and Xcode version.
Comment 16 Alan McGovern 2013-11-11 14:19:11 UTC
If this does not work can you state the Xcode version, MacOS version and also commandline tools version which was installed.
Comment 17 Mikayla Hutchinson [MSFT] 2013-11-11 14:58:02 UTC
Alan, that does not work. Please see my earlier post.
Comment 18 Calin Turcu 2013-11-12 01:38:32 UTC
Yes, that doesn't work, we all tried it already. 

On my machine (see below) I see that "xcode-select -v" returns a different version (2333) than the report from Xamarin Studio (Xcode 5.0.1 (3335.6)). I'm not sure if they are both referring command line tools versions, maybe 3335 is the internal version of Xcode. However, I always installed Xcode in the default location and didn't fumble with its settings. SVN worked prior to Mavericks upgrade.

The details of my configuration:

xcodebuild -version
Xcode 5.0.1
Build version 5A2034a

xcode-select -v
xcode-select version 2333.

xcode-select -p
/Applications/Xcode.app/Contents/Developer

My machine: Macbook Pro, 17-inch, mid 2009
Software  OS X 10.9 (13A603)

Report by Xamarin Studio:
Xamarin Studio
Version 4.0.13 (build 38)
Installation UUID: 9fb52395-0d92-4d31-9fbd-583e45a98291
Runtime:
	Mono 3.2.3 ((no/8d3b4b7)
	GTK+ 2.24.20 theme: Raleigh
	GTK# (2.12.0.0)
	Package version: 302030000

Apple Developer Tools
Xcode 5.0.1 (3335.6)
Build 5A2034a

Xamarin.iOS
Version: 7.0.2.7 (Business Edition)
Hash: 57edee2
Branch: 
Build date: 2013-04-10 18:05:51-0400
Build Information
Release ID: 400130038
Git revision: 07afec667f7be5d0ee511eb7115bbac6377fbae8
Build date: 2013-09-24 08:53:29+0000
Xamarin addins: 61140345a5b109633a94409edcbc7a4c19a425c6

Operating System
Mac OS X 10.9.0
Darwin MacBookPro-D49A20D71456-2.local 13.0.0 Darwin Kernel Version 13.0.0
    Thu Sep 19 22:22:27 PDT 2013
    root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
Comment 19 Alan McGovern 2013-11-12 01:41:47 UTC
(In reply to comment #17)
> Alan, that does not work. Please see my earlier post.
We figured out the issue. The commandline tools for Mavericks now installs the required files in /Library/Developer/CommandLineTools/usr/lib instead of in /usr/lib. We have modified our launcher to load svn from that location.

Thanks for the report and hopefully this will make it to a release soon, but I can't give a good estimate on when exactly that will happen.
Comment 20 Costas Economopoulos 2013-11-12 04:37:23 UTC
Any hotfix until the release?
We are using svn heavily and it is a complete mess when trying to manage a project without svn...
Comment 21 Himanshu 2013-11-18 05:37:31 UTC
Any Release plan ?
Comment 22 Chris Hardy [MSFT] 2014-02-04 10:57:03 UTC
This is fixed with release 4.2.2 and greater. You will also need to make sure with Xcode and OS X 10.9/Mavericks that you have the Command Line Tools installed which you can do from the terminal by typing:

xcode-select -install
Comment 23 Marius Ungureanu 2014-02-04 11:07:40 UTC
Correction on the above. It's:

xcode-select --install