Bug 15390 - xamarin studio axml files don't open after 4.0.13 update
Summary: xamarin studio axml files don't open after 4.0.13 update
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Dominique Louis
Depends on:
Reported: 2013-10-14 16:03 UTC by Keith Longwell
Modified: 2016-08-03 15:24 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Keith Longwell 2013-10-14 16:03:48 UTC

The axml files all opened fine until the 4.0.13 update was installed today.  It now says. 

"The project has resource folders using uppercase letters.  The Android SDK requires all resource folders to be lowercase, otherwise the design may not find the resources in those folders.  The invalid folder are Data.

I changed the folder listed as Data to data.

I have tried changing the files to all lowercase but I can not get it to work.  But it all opened fine in the previous version. 

Any thoughts?

Keith Longwell
Comment 1 Mohit Kheterpal 2013-11-21 09:19:40 UTC
Can you please check this issue with latest stable X.Android 4.10.01073.

If this issue still happens with stable X.Android 4.10.01073. Please provide us a screencast so that we can reproduce this issue.
Comment 2 Mohit Kheterpal 2013-11-21 11:19:55 UTC
I have tried to reproduce this issue with XS 4.2.1 (build 1) and X.Android 4.10.01073. But I am unable to reproduce this issue.

I am able to rename folder from uppercase to lower.

Here are my steps in screencast : http://screencast.com/t/PlWFepCb3

Not sure whether I am following required steps to reproduce this issue or not.

Please verify this issue with latest stable builds i.e. XS 4.2.1 (build 1) and X.Android 4.10.01073.

If you are still facing this issue then please provide us steps to reproduce or screencast.
Comment 3 Keith Longwell 2013-11-21 12:23:49 UTC
Hello Mohit,

After the latest update 4.2.1 the error message changed and now told me that the Google SDK needed to be updated.  

I updated that and it is now working just fine.

Comment 4 narayanp 2013-11-26 08:39:10 UTC
As per comment#3 closing this issue..