Bug 15197 - Unable to play converted audio for iOS Sample 'AudioConverterFileConverter'
Summary: Unable to play converted audio for iOS Sample 'AudioConverterFileConverter'
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 7.0.0.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Sebastien Pouliot
Depends on:
Reported: 2013-10-04 04:57 UTC by narayanp
Modified: 2013-11-18 09:20 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description narayanp 2013-10-04 04:57:21 UTC
Steps to reproduce:
1. Open iOS sample 'AudioCinverterFileConverter'.
2. Debug or run the application.
3. Select Format as iLBC and Rate as 8K
4. Click 'Convert and Play File.

Actual result: audio does not play for Rate 'iLBC' and Rate '8K' while for other it is working fine.

Expected Result: Audio should playe on rate 'iLBC' and Rate '8K'.

Supplement info:
iOS Device Log: https://gist.github.com/AkhileshKumar01/f3410106f08c7d2135ac 
Application Output: https://gist.github.com/AkhileshKumar01/738c9dc1eacf7abe5c81 

App info:
monotouch sample/AudiConverterFileConverter

Environment details:
All Mac
All Xcode
X.S 4.0.12(build 3)
Mono 3.2.3

Regression Status:
This is working fine stable X.iOS
Comment 1 PJ 2013-10-18 12:43:06 UTC
I can reproduce the Audio file not playing with that combination of settings on 

Sebastien, is this something worth fixing in 7.0.3 or 7.0.4?
Comment 2 Rolf Bjarne Kvinge [MSFT] 2013-10-25 04:26:32 UTC
I've just tried with (4cfca2f), and it fails the same way there.

Can you please confirm it is in fact working with 7.0.1 for you, on both device and in the simulator?
Comment 3 narayanp 2013-10-29 12:03:08 UTC
I have checked it with X.iOS and I am getting same issue with this X.iOS as well. But I am not sure how this was working that time with stable X.iOS
Comment 4 Sebastien Pouliot 2013-10-31 12:54:08 UTC
If it existed in 7.0.1 then it's not a regression (and not a blocker for 7.0.3/4). Reseting priority to normal
Comment 5 Sebastien Pouliot 2013-11-15 14:20:39 UTC
Looks like a sample issue where the sample (no pun intended) rate is 48000, not the 8000 selected, when the format is created. That's invalid (and can't be selected) and nothing plays.
Comment 6 Sebastien Pouliot 2013-11-15 14:25:34 UTC
Yes, that was it. Fixed in master / f70bfe626dd5a710a1062374f507c6c83180fdc2

I suspect this never worked before (nothing in the history shows this was changed).
Comment 7 Akhilesh kumar 2013-11-18 09:20:51 UTC
Today, we have checked this issue with following builds:

XS 4.2.1(build 1)
Mac mavericks 10.9
Xcode 5.0.1

Now, Audio is playing successfully on rate 'iLBC' and Rate '8K' in iOS Sample 'AudioConverterFileConverter'. Hence marking this as Verified