Bug 15069 - App crashes because of Xamarin Studio EvaluatorException
Summary: App crashes because of Xamarin Studio EvaluatorException
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 4.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-09-30 11:29 UTC by Jonas Sourlier
Modified: 2013-10-01 10:00 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jonas Sourlier 2013-09-30 11:29:14 UTC
My app suddenly crashed while debugging on the iPad. The following message was in Xamarin Studio's output console:

Mono.Debugging.Evaluation.EvaluatorException: Method `.ctor' not found in type `System.Collections.Generic.CollectionDebuggerView<System.DateTime>'.
  at Mono.Debugging.Soft.SoftDebuggerAdaptor.OverloadResolve (Mono.Debugging.Soft.SoftEvaluationContext ctx, Mono.Debugger.Soft.TypeMirror type, System.String methodName, Mono.Debugger.Soft.TypeMirror[] genericTypeArgs, Mono.Debugger.Soft.TypeMirror[] argTypes, System.Collections.Generic.List`1 candidates, Boolean throwIfNotFound) [0x00215] in /Users/builder/data/lanes/monodevelop-lion-master/222857fc/source/monodevelop/main/external/debugger-libs/Mono.Debugging.Soft/SoftDebuggerAdaptor.cs:1604 
  at Mono.Debugging.Soft.SoftDebuggerAdaptor.OverloadResolve (Mono.Debugging.Soft.SoftEvaluationContext ctx, Mono.Debugger.Soft.TypeMirror type, System.String methodName, Mono.Debugger.Soft.TypeMirror[] genericTypeArgs, Mono.Debugger.Soft.TypeMirror[] argTypes, Boolean allowInstance, Boolean allowStatic, Boolean throwIfNotFound) [0x0024a] in /Users/builder/data/lanes/monodevelop-lion-master/222857fc/source/monodevelop/main/external/debugger-libs/Mono.Debugging.Soft/SoftDebuggerAdaptor.cs:1480 
  at Mono.Debugging.Soft.SoftDebuggerAdaptor.CreateValue (Mono.Debugging.Evaluation.EvaluationContext ctx, System.Object type, System.Object[] args) [0x00070] in /Users/builder/data/lanes/monodevelop-lion-master/222857fc/source/monodevelop/main/external/debugger-libs/Mono.Debugging.Soft/SoftDebuggerAdaptor.cs:343 
  at Mono.Debugging.Evaluation.ObjectValueAdaptor.GetProxyObject (Mono.Debugging.Evaluation.EvaluationContext ctx, System.Object obj) [0x00146] in /Users/builder/data/lanes/monodevelop-lion-master/222857fc/source/monodevelop/main/external/debugger-libs/Mono.Debugging/Mono.Debugging.Evaluation/ObjectValueAdaptor.cs:1106 Assertion failed: (result == KERN_SUCCESS), function +[XPCMachSendRight wrapSendRight:], file /SourceCache/XPCObjects/XPCObjects-46/XPCMachSendRight.m, line 27.

I'm not able to reproduce this, I just think that 'EvaluatorException's and 'CollectionDebuggerView's should not be able to crash my app.
Comment 1 Jonas Sourlier 2013-09-30 11:32:00 UTC
This happened on Xamarin Studio 4.1.7 build 1346, which I downloaded from

https://files.xamarin.com/~jeff/XamarinStudio-222857fc7316a8d26452cb07507b143017a0eda6.dmg
Comment 2 Jeffrey Stedfast 2013-09-30 12:02:21 UTC
The crash and the exception are not related. The exception happens client-side and does not affect the app at all.

I'll look into fixing the evaluator exception but the crash is in some objc code somewhere
Comment 3 Jeffrey Stedfast 2013-09-30 15:33:29 UTC
What do you have your linker settings set to? Do you have it set to link SDK assemblies? It looks like this evaluator exception is because the CollectionDebuggerView<> is getting stripped out.

I've added code to catch this exception, but it'd be good to know that this was the actual reason behind it.
Comment 4 Jeffrey Stedfast 2013-10-01 10:00:36 UTC
fwiw, the exception is fixed now.