Bug 15068 - NUnit is broken on Windows
Summary: NUnit is broken on Windows
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: 4.0.13
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-09-30 11:07 UTC by Jeffrey Stedfast
Modified: 2017-09-28 10:42 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Jeffrey Stedfast 2013-09-30 11:07:32 UTC
When running NUnit tests on Windows in 4.0.13, it gets an internal error about not being able to find one of the nunit dlls or something.

It builds fine, though... I just can't run the unit tests anymore.
Comment 1 Jeffrey Stedfast 2013-09-30 11:14:59 UTC
I thought this only happened after updating to 4.0.13, so I downgraded to 4.0.12 but I still get the error:

http://screencast.com/t/kiJRq4IJTBn5

Maybe I was running 4.0.10 when it worked?
Comment 2 Michael Poulshock 2013-10-15 10:12:36 UTC
When I upgraded to 4.0.13 (build 38), I was suddenly no longer able to build C# projects that reference the nunit DLLs.  I got errors suggesting that I was missing a reference or assembly, when the nunit.framework dll was included.

The exact same project builds cleanly on Xamarin 4.0.12 (build 3).

Needless to say, it is impossible for me to continue developing my project using 4.0.13.

OS: Windows.
Comment 3 Mike Krüger 2013-10-15 10:21:33 UTC
A workaround would be to turn off the msbuild engine in the project options - or - reference the nunit dlls directly (AddIns/NUnit/nunit.framework.dll).