Bug 14960 - SIGSEGV causes simulator hang
Summary: SIGSEGV causes simulator hang
Status: RESOLVED DUPLICATE of bug 11286
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 7.0.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-09-24 15:42 UTC by STAVROS SOTIRCHOS
Modified: 2013-09-25 06:31 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description STAVROS SOTIRCHOS 2013-09-24 15:42:23 UTC
I get the following message and the simulator hangs. The device is ok with no hang at all. Do you have any idea how can I find out what is causing it?

mono-rt: Stacktrace:

Native stacktrace:

Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-09-24 17:25:24 UTC
Are you using any third-party bindings in your app?
Does it happen if you run on the simulator without debugging?
Comment 2 STAVROS SOTIRCHOS 2013-09-24 20:38:59 UTC
Yes i have done custom bindings 

Is there anyway to find out more things about it? Stacktrace etc?
Comment 3 STAVROS SOTIRCHOS 2013-09-24 20:59:02 UTC
And yes it seems to happen only when debugging with the simulator. Tried without debugging and did it without any problem.
Comment 4 STAVROS SOTIRCHOS 2013-09-24 22:11:59 UTC
I found out that the problem was caused by a control I've downloaded, the SDWebImage. Just after removing it everything worked ok.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2013-09-25 06:31:43 UTC
This is a problem with blocks and any calls to SDWebImageManager.SharedManager.Download (possibly other methods too taking a completed callback).

This has been fixed and will be included in a future release (not 7.0.1 which is already going through the release process, but probably 7.0.2).

*** This bug has been marked as a duplicate of bug 11286 ***