Bug 1491 - [svn17] Support for SVN 1.7
Summary: [svn17] Support for SVN 1.7
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 2.8
Hardware: Macintosh Mac OS
: Low normal
Target Milestone: ---
Assignee: Marius Ungureanu
: 5525 10446 ()
Depends on:
Reported: 2011-10-13 22:25 UTC by Neal
Modified: 2013-08-19 10:22 UTC (History)
14 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Neal 2011-10-13 22:25:52 UTC

It seems that up to SVN 1.6 is supported.  Please consider adding support for the newly released 1.7 of SVN (at least tortoiseSVN).

Thank you.
Comment 1 Mikayla Hutchinson [MSFT] 2011-10-21 06:57:56 UTC
Can you be more specific about what needs to be supported in SVN 1.7?

* Are there new features you'd like to see MD support?
* Did the addin stop working with newer versions of the SVN libraries?
* Do you want an easier way to have MD use a newer SVN version than the system SVN installation?

Note that MD uses the system SVN installation on Mac and Linux, which on MacOS X Lion is 1.6.16.
Comment 2 Neal 2011-10-21 09:26:25 UTC

My understanding, which may be incorrect, was 1.7 required changes on the client side.  I have been having problems with SVN integration in MD 2.8.1 which I filed a different bug report on and included the exception detail.  I have since reverted my server back to the 1.6 version even though I hear the 1.7 still works with 1.6 clients so it shouldn't have been a server issue in the first place.  Please test SVN integration with MD 2.8, I was unable to publish a new solution/project, etc.  I am using VisualSVN server 2.1.x (I had updated to 2.5 which uses SVN 1.7 but have reverted to try and get things working).


Comment 3 Mikayla Hutchinson [MSFT] 2011-10-21 09:30:04 UTC
Do you recall whether the MacOS commandline svn worked with the server?
Comment 4 Neal 2011-10-21 09:40:14 UTC
I haven't used nor do I know the command line methods with SVN.  I have been using SVN with MD 2.4 without a problem for over a year, I used 2.6 briefly, and now with 2.8 I'm unable to use it at all for whatever reason.
Comment 5 Alan McGovern 2011-11-15 11:38:07 UTC
To support this you need to install a newer version of svn. MonoDevelop uses the system svn library which is 1.6.16 on macos lion. The simplest thing to do would be to not use tortisesvn, or use an older verison which uses 1.6 style clientside repositories.

You can use either 1.6 or 1.7 on the server side, it makes no difference. You just have to ensure that both applications (built in svn on macos and tortise svn) use the same svn version.
Comment 6 Gustavo Rubio 2012-11-10 18:37:41 UTC
I do not know if this is related or not but in OpenSuSE and Windows SVN does not work anymore either. Tried both 3.0.4 and 3.0.5 versions and while MonoDevelop does check out code it never opens the solution. Also tried opening an already checked out folder but did not work either.

I as going to fill a new bug, but I'm not sure if that would be a duplicate for this... any comments?
Comment 7 Paul Johnson 2013-01-09 07:11:13 UTC
svn 1.7.6 works fine on the commandline, but is not supported in MD 3.x
Comment 8 Alan McGovern 2013-01-14 09:40:29 UTC
*** Bug 5525 has been marked as a duplicate of this bug. ***
Comment 9 Alan McGovern 2013-02-19 20:47:36 UTC
*** Bug 10446 has been marked as a duplicate of this bug. ***
Comment 10 Glenn Wilson 2013-03-06 12:36:46 UTC
Please support svn 1.7 client integration on windows and mac.  

I want to use Xamarin with svn projects that I use with other svn tools that use the svn 1.7 client.  The svn 1.6 and 1.7 clients are not compatible with each other.
Comment 11 Syndog 2013-04-26 12:40:31 UTC
Please add my name to the list of those chomping at the bit for SVN 1.7 support.  The new standard has been out for quite some time now, and this really needs updating.  The fact that this ticket is two years old and still under "NEW" status is frankly appalling.
Comment 12 Lluis Sanchez 2013-06-27 05:37:25 UTC
Support for svn 1.7 has been implemented. It will be included in upcoming releases.
Comment 13 Neal 2013-06-27 09:42:24 UTC
Great to hear, FYI, SVN 1.8 is now the latest.
Comment 14 Tim Jowers 2013-08-19 08:54:15 UTC
also, adding web refernce fails due to this. need to rename .svn restart Xamarin, import web reference. and then have to use cmd line to rename (winblows) attrib filename.xxx -r -h -s 
ren filename.xxx .svn
Comment 15 Marius Ungureanu 2013-08-19 10:22:19 UTC
Will take a look at this. :D