Bug 14821 - Unexpected error, malformed name XA0000 in Xamarin.Android.Common.targets
Summary: Unexpected error, malformed name XA0000 in Xamarin.Android.Common.targets
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.8.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Alex Rønne Petersen
Depends on:
Reported: 2013-09-17 22:53 UTC by emacinnes
Modified: 2013-09-19 12:23 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Screenshot of the error. (162.56 KB, image/png)
2013-09-17 22:53 UTC, emacinnes
Project with the issue (650.71 KB, application/zip)
2013-09-18 20:47 UTC, emacinnes

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description emacinnes 2013-09-17 22:53:24 UTC
Created attachment 4920 [details]
Screenshot of the error.

First compilation of the project worked fine, but after an access violation in the application, and a recompile (to add in a null check), this error came out:

<Target Name="_ScanAssemblies"
			DirectReferences="$(OutDir)$(TargetFileName);@(ReferencePath)" />

with the error:

Unexpected Error - Please fill a bug report at http://bugzilla.xamarin.com. Reason: Malformed Name (XA0000)

This error appeared on the "<ScanAssemblies" line

The only thing slightly different is the Output location of two attached libraries, which were set to:

D:\Projects\Icarus 3.1\Development\Bin\Droid.$(Configuration)

This location exists, and the DLL's are output to here.

I didn't make any platform changes, they were left on the default of 2.2 Froyo, and the project did install the platform and run on an XVGA 1280x800 Atom x86 emulator first time.
Comment 1 emacinnes 2013-09-17 23:01:49 UTC
Restarting Xamarin Studio allowed me to continue working.
Comment 2 emacinnes 2013-09-17 23:05:06 UTC
however,every second compilation of the project does this error and I need to restart Xamarin Studio.
Comment 3 Jonathan Pryor 2013-09-18 12:05:32 UTC
Please provide a copy of the project.
Comment 4 emacinnes 2013-09-18 20:44:38 UTC
During the process of making a bug version (with all other projects removed), I discovered the immediate cause of the issue. The folder the project was kept in has a comma in the name.


If the project is contained in folder: "1. Blank (PC)", then it compiles fine every time.

If the project is contained in folder: "1. Blank (PC, iOS)", then it compiles fine once, but then thereafter there is the described packaging failure.

I have tried combinations of these, with the full stop, with/without the brackets etc.., and it's the comma causing the problem.
Comment 5 emacinnes 2013-09-18 20:47:32 UTC
Created attachment 4926 [details]
Project with the issue

Project Solution is in Examples\1. Blank (PC, iOS, Droid)\Blank.Droid.sln
Comment 6 Jonathan Pryor 2013-09-19 12:19:35 UTC
Setting to NEW, as a sample was provided in Comment #5.
Comment 7 Jonathan Pryor 2013-09-19 12:23:09 UTC
I'm not able to reproduce this issue with 4.8.3 (due any day now...).

Please try using the current 4.8.2 beta.