Bug 14725 - Web Reference problem after update to Xamarin 6.4.5: MT1006:Could not install the application
Summary: Web Reference problem after update to Xamarin 6.4.5: MT1006:Could not install...
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 7.0.3.x
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-09-13 14:29 UTC by Jon Goldberger [MSFT]
Modified: 2017-01-17 18:49 UTC (History)
10 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jon Goldberger [MSFT] 2013-09-13 14:29:24 UTC
I recently updated my Xamarin to 6.4.5 and I am now not able to use my web reference. Upon trying to test my code, I created a new project and a reference to my web service. When I try to debug I get a message saying "MT1006:Could not install the application '/Users/kylew/Library/Caches/Xamarin/mtbs/builds/WebserviceTest/75daeba7-1764-47a3-8a7a-1d1e801c971f/output/Debug/iPhone/WebserviceTest.app' on the device 'Test iPhone': Executable Twiddle Failed Error (error: 0xe8000046). This is usually fixed by deleting the app from the device (and then try again)..". Since I just created the project it is impossible that the application is already installed on the device.

When I run my original project with the web reference issue it debugs fine, but every call to my web service returns "Error getting response stream(ReadDone1): RecieveFailure". When I debug
The exception is "{System.Net.WebException: Error getting response stream (ReadDone1): ReceiveFailure ---> System.ExecutionEngineException: Attempting to JIT compile method '(wrapper delegate-begin-invoke) System.Func`4<byte[], int, int, int>:begin_invoke_IAsyncResult__this___T1_T2_T3_AsyncCallback_object (byte[],int,int,System.AsyncCallback,object)' while running with --aot-only. See http://docs.xamarin.com/ios/about/limitations for more information.

at System.IO.Stream.BeginRead (System.Byte[] buffer, Int32 offset, Int32 count, System.AsyncCallback callback, System.Object state) [0x00072] in /Developer/MonoTouch/Source/mono/mcs/class/corlib/System.IO/Stream.cs:191
at Mono.Security.Protocol.Tls.RecordProtocol.BeginReceiveRecord (System.IO.Stream record, System.AsyncCallback callback, System.Object state) [0x00039] in /Developer/MonoTouch/Source/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs:326
at Mono.Security.Protocol.Tls.RecordProtocol.ReceiveRecord (System.IO.Stream record) [0x00000] in /Developer/MonoTouch/Source/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs:441
at Mono.Security.Protocol.Tls.SslStreamBase.InternalReadCallback (IAsyncResult result) [0x00091] in /Developer/MonoTouch/Source/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/SslStreamBase.cs:682
--- End of inner exception stack trace ---
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00065] in /Developer/MonoTouch/Source/mono/mcs/class/System/System.Net/HttpWebRequest.cs:951
at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse (System.Net.WebRequest request, IAsyncResult result) [0x00000] in /Developer/MonoTouch/Source/mono/mcs/class/System.Web.Services/System.Web.Services.Protocols/WebClientProtocol.cs:200
at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse (System.Net.WebRequest request, IAsyncResult result) [0x00000] in /Developer/MonoTouch/Source/mono/mcs/class/System.Web.Services/System.Web.Services.Protocols/HttpWebClientProtocol.cs:185
at System.Web.Services.Protocols.SoapHttpClientProtocol.AsyncGetResponseDone (IAsyncResult ar) [0x0000e] in /Developer/MonoTouch/Source/mono/mcs/class/System.Web.Services/System.Web.Services.Protocols/SoapHttpClientProtocol.cs:137 }"

I tried http://docs.xamarin.com/ios/about/limitations for more information, but the page is not available.
Version info and test case link:

Version Information:

Microsoft Visual Studio Premium 2012
Version 11.0.60610.01 Update 3
Microsoft .NET Framework
Version 4.5.50709

Installed Version: Premium

LightSwitch for Visual Studio 2012 04941-004-0043007-02149
Microsoft LightSwitch for Visual Studio 2012

Office Developer Tools 04941-004-0043007-02149
Microsoft Office Developer Tools

Team Explorer for Visual Studio 2012 04941-004-0043007-02149
Microsoft Team Explorer for Visual Studio 2012

Visual Basic 2012 04941-004-0043007-02149
Microsoft Visual Basic 2012

Visual C# 2012 04941-004-0043007-02149
Microsoft Visual C# 2012

Visual C++ 2012 04941-004-0043007-02149
Microsoft Visual C++ 2012

Visual F# 2012 04941-004-0043007-02149
Microsoft Visual F# 2012

Visual Studio 2012 Code Analysis Spell Checker 04941-004-0043007-02149
Microsoft® Visual Studio® 2012 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Visual Studio 2012 SharePoint Developer Tools 04941-004-0043007-02149
Microsoft Visual Studio 2012 SharePoint Developer Tools

Microsoft Practices Project Linker 1.0
Microsoft patterns & practices project linker

NuGet Package Manager 2.2.40116.9051
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer 1.0
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools 11.1.30618.1
Microsoft SQL Server Data Tools

Web Developer Tools 1.2.40308.0
Microsoft Web Developer Tools contains the following components:
Page Inspector: Tool that offers an efficient way to decompose Web Applications and diagnose front-end issues.
Web Publishing: Extensions required for Web Publishing for both hosted servers as well as on premises.
Web Form Templates: Includes the default templates for Web Form Applications.
Editor Extensions: Includes HTML, CSS, and JS editor extensions that greatly enhance the development experience.

Xamarin.Android 4.8.01013 (b76e8ec4)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS 1.3.250 (49348a51)
Visual Studio extension to enable development for Xamarin.iOS

Here is the test project that I created in Visual Studio that threw the Unable to install exception.

Comment 2 Brian Graham 2013-09-13 14:47:10 UTC
Sorry I figured out the Problem with the Unable to Install application. I was able to get the application to install however I am still getting the "Error getting response stream(ReadDone1):RecieveFailure" message for my webservice.

this is my new version of the Test Project

Comment 3 Jérémie Laval 2013-10-31 13:15:48 UTC
Moving the bug to the general Xamarin.iOS product since it's not VS related anymore.
Comment 5 Sebastien Pouliot 2017-01-17 18:49:36 UTC
The test case is not available anymore. If this is still an issue then please re-open with a test case. Thanks.